Sign in with
Sign up | Sign in
Your question
Closed

Black screen after GPU upgrade

Last response: in Graphics & Displays
Share
November 25, 2012 6:48:28 PM

I'm upgrading my GPU from a Radeon x1600 Pro 512mb to a XFX Radeon 5770 1gb.

First I uninstalled the drivers from the old card in device manager. Then I disconnected my power supply first then the rest of the wires. I opened up my case and replaced the old card with the new one. I connected all of the wires back and the PSU wire connected last.

Here's what happens when I turn on my computer:
- All of the fans spin much faster than usual.
- Nothing comes up on the monitor. It just stay black as if the computer was off.
- No sounds come from the computer at all. No beep codes or the sound of Windows starting up.


Here's what I've tried:

- Check to make sure the card is fully seated in the PCIe slot.
- Made sure the 6 pin PCIe connecter is fully connected to the card.
- Made sure that PCIe is what is selected in the system bios.
- Swapped out the new card to the old one to see if it works with the old card back in and it does.

Here's my system specs:

Windows 7 Ultimate 64bit
Ati Radeon X1600 Pro 512mb (old card) XFX Radeon 5770 1gb (new card)
3gb RAM (to be upgraded later)
AMD Athlon 64 Processor 3500+ 2.20ghz (Also to be upgraded later)
Thermaltake 600w PSU
MSI MS-7093 Motherboard (HP motherboard name: Albacore-GL6E)

Any ideas?

Best solution

November 25, 2012 7:38:54 PM

Your motherboard has a 1.0 express slot, card is 2.0. That shouldn't make a difference, but looks like it does here. Can't think of anything else. Maybe check the BIOS - set boot up to PEG for PCI Express and try DVI or HDMI.
Share
November 26, 2012 9:17:06 AM

Best answer selected by IIConceitedII.
Score
0
!