I got 2 beeps and no display on my video card

Mainboard : Emaxx Technologies, Inc EMX-MCP61D3-iCafe
Chipset : nVidia GeForce 7025
Processor : AMD Athlon II X2 260 @ 3200MHz
Physical Memory : 4096MB (1 x 4096 DDR3-SDRAM )
Video Card : NVIDIA GeForce 7025 / NVIDIA nForce 630a
Hard Disk : Hitachi HDT725032VLAT80 ATA Device (320GB)
DVD-Rom Drive : ELBY CLONEDRIVE
Monitor Type : 96VD - 19 inches
Network Card : Realtek Semiconductor RTL8168/8111 PCIe Gigabit Ethernet Adapter
Operating System : Windows 7 Ultimate Professional Media Center 6.01.7600 (32-bit)
DirectX : Version 11.00
Windows Performance Index : 3.2 on 7.9
Bios : American Megatrends Inc.

i got two beeps whenever i start my computer. its weird because when im using pc with the same bios and mainboard, it beeps only once. also my video card is not working. but when i found a chance to insert it in other computer, it works perfectly fine! i tried also the possible solutions and nothing works. also i have a strange observation on my RAM. there are times it decreases it's memory to 1 Gigabyte. i also can't flash update my bios. there is an error when i try to. please help..
11 answers Last reply
More about beeps display video card
  1. btw im using the onboard graphics.. my video card is ATI Radeon HD 2600 Pro
  2. 2 Beeps
    Two beeps means there has been a parity error in base memory. This is an issue with the first 64KB block of memory in your RAM. The solution is usually to replace the memory.
  3. but i can still use the computer even if it has an error.. is that normal?
  4. Well the ram is faulty. So you better change it .
  5. ok.. thanks.. i'll reply soon as i changed my ram..
  6. Ok :)
  7. UPDATE: i turned off in BIOS the beep when computer is turned on. still it produces 1 beep. i reseated my ram, clean it, change slot but still it has beep.
  8. well 1 beep is the PC posting. Does the computer boot normally ?
  9. there is a option in the bios that i can disable the normal boot beep. and still im getting a single beep. there is no display in the video card but the onboard is working. the computer boots normally after that.
    i encountered past problems like the RAM has decrease its memory from 4GB to 1GB but when i reseat the RAM,it returns to its original memory.

    so i think the RAM is faulty..
  10. I told you to try a different ram. Or try them 1 by 1 in each slot
  11. sorry for the late reply, prototype28.. no internet for a month is haaaard!
    well i tried changing the RAM.. It fixed the problem of the beep but still there is no display on video card.. only onboard graphics is working.. the video card is still working on other computer..
Ask a new question

Read More

Graphics Cards Graphics