How to make my laptop actually use its friggin dedicated gpu?!?!

So I have an Acer laptop which supposedly has a powerful dual GPU setup in crossfire mode, with the integrated 6520G and dedicated 7670M. However, in every game I run the performance is such crap, like 15 FPS in low settings 800x600 resolution. This makes no sense as people run BF3 on 1366 res and ultra with 40+FPS with the same setup, and my friend who has the Intel 3000 HD + GTX 540M is able to run Chivalry Medieval Warfare on high settings 1366 and 40 FPS (while my Chivalry runs 15 FPS 800x600...Lowest settings possible), which theorecially is weaker than my setup... He just simply tweaked in his Nvidia control panel and got his laptop to use dedicated in order to fix low FPS. But since my cards are ATI, how do I do the same? That is make it so that the Laptop uses both GPUs like advertised, or at least use the 7670M over the stupid crappy integrated one?

Thanks in advance!

Edit: So I went into Devce Manager and disabled the 6520G to see what happens.. Now my entire desktop resolution is messed up. Its max res is 1024 by something and when I try torun chivalry it tells me "Your videocard does not support alpha blending with floating point render targets" and exits the game... It seems that my 7670M is not even working... Please help me thanks.
3 answers Last reply
More about make laptop friggin dedicated
  1. PS I cant even start the AMD VISION ENGINE CONTROL CENTER because of an error :" The AMD Vision Engine Control Center cannot be started because there are no settings to configure" or something like that..
  2. Bump. Its been 2 days. I got CCC and set my games up to use the "High Performance Processor" option. However it seems that my laptop still refuses to use the 7670M, as I lag as much as before, and when I force the 6520G off in the device manager the computer goes back into no gpu mode......

  3. I have a 7670m as well but no other dedicated gpu. I can run my games at high settings quite well without needing to tamper with any computer settings. I'm presuming it's something to do with your 2-way gpu setup, if I were you I would see if there are any settings panels about crossfire specifically.
Ask a new question

Read More

Graphics Cards Laptops GPUs Graphics