Sign in with
Sign up | Sign in
Your question

Why isnt my gpu working??

Last response: in Graphics & Displays
Share
November 26, 2012 4:43:27 PM

Why wont my gpu work?
I bought the amd 6670 gpu for my pc, ive slotted it in, and when i turn on the pc, the gpu fan starts running. When i try to put the vga cable from monitor to graphics card, the screen goes black and nothing happens. The device dosnt show up on device manager.

Whats going on??

Even when i disable the amd 3000hd ( my intergrated) my new 6670 doesnt show up....


power supply= 750w

specs: FX 4100 Quad Core 3.60 GHz x4 4GB RAM 500GB HD

More about : isnt gpu working

November 26, 2012 4:47:35 PM

clemontine36 said:
Why wont my gpu work?
I bought the amd 6670 gpu for my pc, ive slotted it in, and when i turn on the pc, the gpu fan starts running. When i try to put the vga cable from monitor to graphics card, the screen goes black and nothing happens. The device dosnt show up on device manager.

Whats going on??

Even when i disable the amd 3000hd ( my intergrated) my new 6670 doesnt show up....


power supply= 750w

specs: FX 4100 Quad Core 3.60 GHz x4 4GB RAM 500GB HD

make sure the card is in all the way.... this has happened to me
November 26, 2012 4:49:53 PM

how do i knnow if its in all the way, i dont want to push it hard because its very fragile, the fans on, doesnt that mean its in??
Related resources
November 26, 2012 5:02:07 PM

clemontine36 said:
how do i knnow if its in all the way, i dont want to push it hard because its very fragile, the fans on, doesnt that mean its in??

well either its one of 3 things.....1 bad card and RMA......2 bad psu........3 not pluged in all the way. remove the card and reinsert and get at an angle if you can to watch it go in. the card should take a little bit of force to go in but not too much....
November 26, 2012 5:06:51 PM

i cant beleive how stupid i am, the card wasnt in propery, thanks so much!!
November 26, 2012 5:09:21 PM

clemontine36 said:
i cant beleive how stupid i am, the card wasnt in propery, thanks so much!!

no prob..... :wahoo: 
November 26, 2012 7:27:38 PM

clemontine36 said:
i cant beleive how stupid i am, the card wasnt in propery, thanks so much!!


Stupid is as stupid does. . . .

Thanks for sharing this with us. I hate it when a guy has a problem and doesn't share what the fix was.
!