Sign in with
Sign up | Sign in
Your question

XFX 7970 crossfire not working properly

Last response: in Graphics & Displays
Share
November 27, 2012 12:00:07 AM

Hello ^^

Until recently my system only had one XFX 7970 double dissapation, but recently I was able to purchase a second one due to some tax returns. I expected a lot from it but so far I've been a bit dissapointed since it's not working properly, and I'm pretty sure I'm not doing anything wrong. I'll explain:

I received my second GPU and installed it, but before continuing I decided to reinstall Windows Home Premium 64bit. Start of with a clean sheet. I installed all motherboard drivers, did 1 restart for updates and installed Catalyst and it's CF profiles. I finished the installation and restarted my pc a few times to complete all windows updates.

After that I decided to check if CF was functioning, so I turned it on and restarted my PC again. It recognised both cards, only difference between them is ofcourse the Bios version.
CCC screenshot
http://www.freebits.nl/images/310blabdiebla.jpg

The problem I have is that the slave card doesn't do... well anything. When i run any game or MSI kombustor, the first card reaches 100% load and the second one stays at a cool 0% load. Only reason it heats up is from the top card blowing hot air against it.

I have tried reinstalling CCC, I have tried reinstalling CCC and leaving away all monitoring progams like afterburner and gpuZ, I have tried disable EnableULPS in register... none of it helped. As you can see my 3Dmark11 score is also down, you'll allso see some of my other system specs like Mobo.
Can someone help me out>?


EDIT:
I have a Cooler Master Silent Pro M2 720W which should delive enough on the 12V line to sustain crossfire.
November 27, 2012 12:14:30 AM

Probably a dumb question, but did you enable crossfire in CCC?
November 27, 2012 12:25:13 AM

Not that dumb, I myself have seen many cases where people forgot it. But for me thats not the case, I'm out of solutions myself. Hoping someone here can help me out.
Related resources
November 27, 2012 2:27:59 AM

Your 3dmark graphics score looks about right for your setup
November 27, 2012 2:38:47 AM

I would contact XFX Support. I hear they are really good.
November 27, 2012 8:14:32 AM

you just use warranty or call XFX support,if you graphic card is still not working in crossfire x (sorry if i wrong)
November 27, 2012 9:31:45 AM

Get MSI Afterburner and turn on the OSD with plenty of GPU details for both GPUs, like load, clocks, usage, voltages, etc... Play some games and see if both GPUs are being used or not. Make sure that all games run in FULLSCREEN! Crossfire does not work in windowed mode.

Also try switching the graphics card around to ensure that the 2nd GPU isn't faulty.
November 27, 2012 10:10:23 AM

Also try changing the crossfire bridge
!