Asrock Extreme4 Not Booting Windows 8

So I just built my PC and when I tryed to install windows 8 it was being funny and I would just turn it on and it would just have a black screen right after the ASRock logo and btw I could get into the BIOS if needed. I cleared the CMOS and window 8 booted up and got installed. I got done downloading the navidia drivers and when I restarted the comp it just kept flashing on a black screen. So i turned it off and turned it back on it was doing the same thing as before I installed showing the AsRock then just a black screen like the problem before I cleared the CMOS and installed windows 8. So i took that drive and put it in my old comp and windows 8 booted up just fine. So I figured it might have been the drivers so i erased them. So now the problem remains Windows 8 not booting on the ASrock and I have changed the boot order a million times.


Any help would be appreciated thanks!
6 answers Last reply
More about asrock extreme4 booting windows
  1. What is your motherboard exactly?

    What is your processor?
  2. I am uploading a video of me showing the problem, should be up in a few hours.
  3. Download the latest BIOS from the boards webpage , and flash the motherboard from a memory stick .
    There are instructions on the website about how to do this .

    I have seen Asrocks UEFI BIOS behave like this before . So even if its not a newer version than the one you have try flashing it with a fresh copy
  4. I just rebuilt my computer the other day with the same motherboard and a 3570k. I reinstalled Win 8, which I already had before, and upgraded it to pro and it's been running great.

    The first time I installed Win 8 though, I installed the pro upgrade version by itself and I did have a couple issues(BSOD, Slowdowns, etc.). After I did my research and figured out I messed up, I reinstalled Win 8 Pro correctly and it's been running really well. I don't know if that helps, but it was the only issues I had.
  5. jthill909 said:
    I just rebuilt my computer the other day with the same motherboard and a 3570k. I reinstalled Win 8, which I already had before, and upgraded it to pro and it's been running great.

    The first time I installed Win 8 though, I installed the pro upgrade version by itself and I did have a couple issues(BSOD, Slowdowns, etc.). After I did my research and figured out I messed up, I reinstalled Win 8 Pro correctly and it's been running really well. I don't know if that helps, but it was the only issues I had.
    I downloaded the BIOS update and went to update. When I turned it on windows 8 decided to boot up all the sudden lol. So no I am downloading WOW and other things (they will be downloading over night) when I turn it off the next time when I got to bed and it does not come back on i will flash the BIOS to the newest verison and that should fix it, but for now windows 8 is running and I am downloading wow. So I will update you Tomorrow when I turn it off and turn it back on.


    Thanks for all the help!
Ask a new question

Read More

Homebuilt ASrock Windows 8 Systems