Sign in with
Sign up | Sign in
Your question

Faulty Graphics Card. RMA?

Last response: in Systems
Share
January 12, 2013 10:07:02 AM

Hi all.
So i just built my first computer a few hours ago and everything went smoothly until I put in my graphics card.
Before putting it in the computer would power on and boot normally.
After putting it in the computer, the computer would either a) not turn on or b) turn on but not post.
Wondering if I got a faulty graphics card and wanted to ask what I should do.

Computer Specs:
i5 3470
Asrock Mobo
Seagate Barra 1tb
MSI Radeon 7850 2gb
Corsair Builder 600w

When the computer does turn on, the fans of the graphic card spins. Does that mean the problem could potentially be linked to the motherboard instead?
Related resources
a b U Graphics card
January 12, 2013 2:35:57 PM

Hi,

Did you plugin the extra power cable (6 pin) to the card?

Look at the memory and power cables, be sure thy didn't loosen while installation.

Do you use a hdmi to vga adapter or something ?
January 12, 2013 2:50:23 PM

dextermat said:
Hi,

Did you plugin the extra power cable (6 pin) to the card?

Look at the memory and power cables, be sure thy didn't loosen while installation.

Do you use a hdmi to vga adapter or something ?

Yes, I've tried both power cables for the gpu. The thing is that the gpu turns on, with fans running, but the computer will not post. I'm trying to figure out if its the mobo slot thats wrong or the gpu.
January 12, 2013 7:46:10 PM

Tried both ram slots with one ram stick each. Computer posts.
Tried taking off everything but the cpu, cpu cooler, ram, psu and power switch. Computer posts when powered up.
Tried GPU in both pcie slots on mobo with alternate 6 pin power cables. Computer does not post either time. :( 

I don't really know what to do know.
!