Sign in with
Sign up | Sign in
Your question

Installed new 7850, blurry text?

Last response: in Graphics & Displays
Share
November 28, 2012 9:16:10 PM

I just installed a new HIS 7850 and I'm noticing that the text is slightly blurry (or more specifically, not crisp as it was when I only had integrated graphics).

I had to enable overscan so that the entire picture would fit my monitor (1080p native). I bumped up the AMD Catalyst (ver 12.10) to max overscan and then on my monitor, selected "auto" for overscan. This filled up the screen nicely, but it doesn't appear as if the text is as crisp anymore.

I went through the Clear Text options through Windows and selected which text appears best to me, but I did not see a difference/change.

Non-crisp text occurs with flux on and off.

Please help, going crazy over here trying to figure it out!

More about : installed 7850 blurry text

a b C Monitor
November 28, 2012 9:18:06 PM

Try going into Catalyst Control Center and ensure that the Morphological Filtering checkbox under Gaming Graphics is not checked. Morphological filtering is a post processing filter that is supposed to help smooth out edges in games. The problem is it also blurs the image, both in game, and on the desktop and 2D applications.
m
0
l
November 28, 2012 9:54:30 PM

Supernova1138 said:
Try going into Catalyst Control Center and ensure that the Morphological Filtering checkbox under Gaming Graphics is not checked. Morphological filtering is a post processing filter that is supposed to help smooth out edges in games. The problem is it also blurs the image, both in game, and on the desktop and 2D applications.


It was not checked by default :/ 
m
0
l
Related resources
a b C Monitor
November 28, 2012 10:34:07 PM

Could be that running overscan both with the video driver, and on the monitor at the same time is causing this problem. Maybe try disabling overscan on the monitor menu and just let the video driver handle it, or see if you can force overscan with just the monitor and leave the setting at default in the Catalyst Control Center.
m
0
l
November 28, 2012 11:38:00 PM

Have a check to see what mode your outputting to the monitor, if it is 1080p the image should be sharp, if the mode is set to 1080 interlaced mode that will be the problem.
Overscan btw will force Interlaced mode. when your using interlaced mode dont forget it only displays alternate lines of the image in fast refresh mode the end result is text on screen looks bad.
m
0
l
December 22, 2012 5:30:17 AM

I have the same problem. The screen is crystal clear on my VGA connection (from mobo) but the text is blurry and tiles and icons seem to be of very low quality/ resolution when connected through HDMI of Gigabyte HD7850.. Drivers are latest. I am wondering what could be the issue
m
0
l
December 22, 2012 6:38:31 AM

My solution:

1. Restart computer after installation of newest drivers
2. Reset the overscan function on monitor
3. Restart computer
4. Reset the overscan function on video card
5. Restart computer
6. Enable overscan on video card to maximum
7. Restart computer
8. Enable overscan on monitor to fit the edges of the screen
9. Restart computer
m
0
l
December 22, 2012 6:51:18 AM

Thanks rebelx. Will try it out today
m
0
l
December 22, 2012 12:38:17 PM

I tried the suggestions.

@ 8. Enable overscan on monitor to fit the edges of the screen
The desktop screen extended beyond the screen.
After 9. Restart computer
Its all the same (bad quality) except that now desktop is bigger than screen.

:( 

m
0
l
December 22, 2012 12:59:28 PM

I just figured it out.
When "Enable GPU scaling" was unchecked, the resolution of 1080p was crappy.
At this setting, when I selected 1680 x 1050 it was much better. But of course it was stretched.
Later I enabled GPU scaling... everything is fine! Getting 60hz on 1080p
I am a lot relieved now! :) 
m
0
l
!