BIOS will not load, system will not boot

I installed new RAM and an SSD today. My computer started up fine, but BIOS would not load. As in, the option to enter BIOS never showed up. If I held down the key to enter BIOS, it wouldn't reach the windows login screen.

2.Partitioned/formatted SSD, since it was already plugged in and it seemed like a good idea at the time.

3. Started the setup.exe file on my windows 7 disk, told it to install windows 7 on my SSD, it was loading fine, went to take a shower because it was going to take a while.

4. Came back, black screen, monitor says "no signal"

5. power on/power off, no signal.

6. unplugged the SSD to try to boot from old hdd, no signal

7. tried all 3 ways recommended to clear CMOS (jumper cap, switch on back, remove battery for a few minutes and put back in), still no signal, still no BIOS.

8. Just tried powering on computer with nothing attached to the motherboard except the PSU, CPU, and heatsink fan. This thread http://www.tomshardware.co.uk/forum/page-262730_13_0.html said it's supposed to beep because of the fact that there is no RAM, it does not beep. All of the lights come on, The light showing the temp the CPU(?) is running at comes on, the heatsink fan comes on, but it does not beep. Before I unplugged everything else, the case fans all ran and the optical drives both opened and closed fine.

At this point (with nothing attached except the CPU, the PSU, and the heatsink fan, I don't get a beep of any kind, I (obviously) still get no signal to the monitor, and I can't turn it off with anything except the PSU switch on the back.

So.. Is my mobo dead? If it's not dead, how do I fix it so I can access BIOS (jumper cap, removing battery didn't work)? How would I know if it's the mobo, the CPU, or the PSU that's dead (preferably without buying any extra equipment)? Any idea why installing windows on the ssd from the hdd would have killed any of these parts that seemed to be fine (it allowed me to log into windows even though BIOS never showed up) before that step?

Specs:
cpu- intel core i5 2500k
mobo- asrock z68 extreme3 gen3
RAM (old)- unsure, label has an M with a circle through it, was stock RAM in old prebuilt HP.
RAM (new)- corsair vengeance 8gb x2, 1.50V
PSU-Seasonic M12II-620 Bronze
Graphics card: EVGA GTX 460

Anyone with experience, please help.
5 answers Last reply
More about bios load system boot
  1. My guess is you had an ESD when you installed the memory, how did you protect the computer from an ESD when you installed the memory?
  2. A rosewill antistatic wrist strap clipped to the case with the psu plugged in (but off)
  3. are you still trying to use the "old" ram?
    You may not hear any "beeps" because you might not have a system speaker.
  4. If 2 rams work in different clock speed blue screen error appears .
    check mobo is working in other psu , remove gpu, plug monitor in internal gpu, remove cmos battery (don't insert) ,
  5. I fixed it somehow. Unplugged/replugged everything, reset CMOS again, and BIOS came up with no problem. No idea why it wouldn't come up the first 12 times I reset CMOS, but I'm not complaining.
Ask a new question

Read More

Homebuilt BIOS SSD Systems