Sign in with
Sign up | Sign in
Your question
Solved

B2 Error

Last response: in Systems
Share
January 14, 2013 2:36:43 AM

Hello guys, I have yet come in contact with another odd error. This tine I get the error "b2" on my mother board which says "Legacy Option ROM initilization". I have no idea what this means, all I know is that I only get it when I have my video card plugged in. It was working fine until it went to sleep, when I tried to turn it on, nothing. Reset power switch and here comes in the errors. Any suggestions? I've looked through the BIOS for anything that might help, but nothing hap helped so far. I've cleared CMOS a few times but have yet to completely take it out. Would that help?

System specs in my signature, and my PC is only about 3 weeks old and has been working fine until now.

ALSO: I can get into the BIOS and do everything with the integrated graphics. It's just then whenever I try to use the video card my system refuses to POST

More about : error

January 14, 2013 2:51:08 AM

try reseating your video card.
m
0
l
January 14, 2013 2:52:32 AM

I also found this from another user on the web: think you have the Asrock z77 Extreme 4 motherboard. That's what I have, and have sort of the same issue. What my new PC does is turn on by itself and then sits at the BIOS screen showing a list of devices with the b2 error code on the bottom right of the screen and on the motherboard itself. I have no idea what this is either. I went into the Boot section of the BIOS (Hit delete key when computer first turns on), and switched it from Legacy to EFI. I am not sure if that will make a difference or not. Whenever I hit the reset button it boots up fine. I just don't know how or why it starts up all by itself.
m
0
l
Related resources
January 14, 2013 3:19:34 AM

Well since when my video card has been pulled in and out numerous times after figuring out that it was it that it was it that was causing the problem, so I'm pretty sure It has been seated properly.

When the video card is seated... Nothing happens. No POST, no signal to my monitor, nothing. Just a big old error code. But everything works, fans, HDD, LEDs. Everything.

And I use the Asrock Z77 Performance motherboard.
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
It's basically the same as the Extreme4 but +/- a few features.
m
0
l
January 14, 2013 3:22:17 AM

One user found that when the card is not perfectly seated in a very particular manner, it gave that error.
Btw, I don't have that motherboard, that was a copy and past post from someone with your same problem.
m
0
l
January 14, 2013 3:28:33 AM

I'll try reseating the card. How would you recommend putting it in horizontally? My Zalman Z11 case really can't be leaned sideways because of the side panel shapes.
m
0
l
January 14, 2013 3:33:31 AM

no, the user had said that it was very finnickly.. just plain around with it; it could be a bad slot now and losing contact with the card...
m
0
l
January 14, 2013 3:35:50 AM

anyhow, make sure that you are not using the legacy bios and use the Eufi gui bios instead if you have the option.

Make sure that you are also using your motherboard's newest bios also.
m
0
l
January 14, 2013 3:49:31 AM

I just updated to the latest UEFI BIOS (2.0) and reseated and that doesn't seem to work either. Throughout this whole time, I've been using the UEFI BIOS. But I find it odd that just right in the middle of being on sleep it decides to do this >_>
m
0
l
January 14, 2013 4:40:16 AM

does your motherboard have have Clr Cmos button on it? I'm not certain how you tried to clear the CMOS, but Z77 Extreme has a button to do it per what I read.
m
0
l
January 14, 2013 4:53:16 AM

Well I've tried the clear CMOS button at least 5 times, temporarily taken out the battery once. I've also tried resetting the default BIOS settings through the bios (Integrated gfx) yet to no prevail. I hope I can get this working soon because I'm not going to be able to play Chivalry on ultra with HD 2500!!!
m
0
l
January 14, 2013 5:12:16 AM

I'm at a loss too; Not much info on the web about that "legacy...."
try booting up without any usb devices attached at all.

If you have another PCIe slotto try, try that with the video card.
Try a different pcie card if you have one available.
Try booting up with only one ram stick at a time.
m
0
l
January 14, 2013 5:22:27 AM

I'm pretty sure a "legacy" BIOS refers to the old blue & white ugly BIOS. I could be wrong though. I've tried with the RAM already, and I really would like to avoid trying to try the other PCI-E lane, as the PCI slot overs are not replaceable, leaving a big hoke in the back of my computer. I'll try with no USB devices though.
m
0
l
January 14, 2013 5:29:13 AM

That did not work either. This has turned out to be on POS of a weekend. I've emailed both Powercolor and Asrock for support. Hopefully they won't tell me that I'm going to have to RMA my video card.
m
0
l
January 14, 2013 7:31:36 PM

Come on guys, this is disappointing, only 1 person has attempted to help so far :(  and yet the problem is still not fixed. Anyone else have a suggestion?
m
0
l
January 14, 2013 7:37:39 PM

BreadWhistle said:
Come on guys, this is disappointing, only 1 person has attempted to help so far :(  and yet the problem is still not fixed. Anyone else have a suggestion?



Yes, the non-Uefi bios is the old blue and white one, or some other two color combo, and without mouse support.

Also, I am also surprised that no one else on here has responded.
m
0
l
January 14, 2013 7:39:31 PM

one thing that you can try is "bread-boarding" it (no pun intended).
m
0
l
January 14, 2013 8:34:07 PM

I have thought about that but decided to put it off for as long as I can. The motherboard was a PITA to get installed correctly. My thumbs went through hell. But if all else fails, I guess I have no choice.
m
0
l
January 15, 2013 12:45:40 PM

Tried that, still not working. The only thing that was fixed were a few loose motherboard screws :/ 
m
0
l

Best solution

May 26, 2013 1:01:44 PM

check your motherboard manufacturers site and see if they have a bios update that fixes gfx card compatibility issues. if yours is older and my benefit then update your bios with the old card in then try the new 1s the bios update takes.

but honestly if your getting b2 it often means the card is doa. you could of course try the new card in a different build and see if it works on that. but its likely it will beep 3 times or b2 code as well.
Share
May 26, 2013 6:16:56 PM

Haha, you are a bit late my main man. But yeah, it was a bad graphics card unfortunately. Sent the Vortex II back to PowerColor and got a Myst Ed. back haha, so it all worked out for the good. Thanks guys
m
0
l
June 1, 2013 1:10:48 PM

then say thanx to the forum member who gave you the right answer by picking theres as such.
m
0
l
December 8, 2013 10:20:22 AM

I encountered this "B2" error with my ASUS gtx 770, it turned out for me at least it was the Video Cards BIOS. Put it in my friends computer and it booted fine. Downloaded the Latest BIOS from ASUS and updated the card, put it in my machine and it booted on the first try xDD
m
0
l
!