Sign in with
Sign up | Sign in
Your question

Integrated Graphics getting better FPS than my Dedicated Graphics

Last response: in Graphics & Displays
Share
December 1, 2012 2:38:25 PM

Hey guys, i wonder if you can help me out a little.

Alienware m14x, the dedicated graphics is GT 555m 3GB GDDR3 , the integrated is Intel(R) HD Graphics 3000.

Now the thing is when i run PS2 on my Dedicated graphics on really low res, with LOW everything and Render quality at about 10% (which makes it look like ***) i achieve about 25 FPS on my own and about <10 FPS if there is any fighting going on. It just makes the game unplayable really. Here is the GPU-Z image from using the Dedicated Graphics:



So what i can see here is that the dedicated GPU never goes about a 20% Load, which i thought was strange. Anyway this was giving me about 15 FPS, and 25FPS when im on my own (although it looks like ***)



So here is my Integrated graphics, the GPU load peaks all over the place but get this, at exactly the same settings on PS2 i get 20 - 30 FPS in a fight and 40 + FPS on my own,

So whats going on here then? i mean i can play it on my integrated graphics but it looks like ***!, and i have my dedicated graphics so i just want to play it at low settings with decent render quality.

So any idea guys?

Cheers
a c 109 U Graphics card
December 1, 2012 2:45:02 PM

Go to the nvidia panel under managing 3d settings go to programs settings and add PS2 game then choose High-performance NVIDIA processor.
See if it uses the gpu.
a b U Graphics card
December 1, 2012 2:46:22 PM

Have you tried a driver update yet? I am not sure if PS 2 supports mobile chipsets, and if so, you will have to get a driver update if you haven't done yet.
Related resources
December 1, 2012 3:09:13 PM

Yep i have the latest Nvidia driver for the GPU.

i went into the Nvidia Control panel, i had allready setup and added PS2 to be using the high performance Nvidia Processor, and still the intergrated graphics is running better in game.

its got me wacked!

a c 109 U Graphics card
December 1, 2012 3:24:07 PM

Well it's the mobile card that isn't supported by PS2, since it has a really low usage either wait for a patch that will be included to support that gpu or some new nvidia verde driver(there is a high change also of not happening).
December 1, 2012 4:21:33 PM

hey guys

Well it looks like i fixed it,

All i done was set the card to use the games settings , then delete the user preferences in the steam file, and pow the game now runs at 30FPS, occasionally dipping to 15FPS in large battles.

Cool

lol
!