Problem with my System

Hi,
I am new to the forum but this is where I have always came to fix my problems but it has been anonymous browsing. Basically my problem has been occuring ever since I came back from a LAN where my System had shorted of some kind. What happened was...

I setup my system at the LAN for obvious reasons and I pressed the power button and the PC just flashed and then switched off it did this multiple times and now I am suffering with the problem when I turn off my PC everything stays on but the PC has shut down e.g. My LEDs, Heatsink and case fans are still functioning the only way I can stop this is if I turn my PC off by the PSU Also If I move the PC say from one place to another It won't switch on so I have to re-seat everything in the system then wait 10 minutes for it to turn on.. It is not much of a problem but it has come to the point where it has started to agitate me. My system is pretty new other than my GPU.

Specs:
Noctua NH-D14
i5-3570k (Stock Clock)
16GB Corsair Vengeance RAM
Sabertooth Z77 Motherboard
Corsair AX850 PSU
Corsair 600T Case
120GB OCZ Agility 3 SSD
1TB Samsung Spinpoint HDD

Thanks to anyone that tries to help me

All the best
Brad
2 answers Last reply
More about problem system
  1. Have you tried clearing CMOS or using a different power supply?
  2. thebigbug said:
    Have you tried clearing CMOS or using a different power supply?


    I have tried this but it hasn't fixed anything
Ask a new question

Read More

Homebuilt Systems