Sign in with
Sign up | Sign in
Your question

DVD quality is grainy and pixellated

Last response: in Storage
Share
January 12, 2002 6:40:24 PM

Hi, I really hope you can help me because this problem is making me tear my hair out.

I bought a 12x DVD player a few weeks ago, and the quality of the picture is pretty poor. On WinDVD (OEM version) it seems to pixellate every second or so, with a slight dip in brightness at the same time. I installed PowerDVD (trial version) for test purposes, and although the regular pixellation does not seem to be present, the visual quality is still very grainy, and seems to be of a lower quality than WinDVD (the lines are less smooth and more "computery".) Additionally, the screen seems to shake very slightly in PowerDVD.

The playback is perfectly smooth with no pauses - it's just the visual quality that is poor. I've tried it with the latest test version of WinDVD with no improvement, and fiddled with all of the decoder settings to no effect.

I've tried the following things with no luck:

1) Changing resolutions and refresh rates
2) Updating VIA 4-in-1 drivers
3) Enabling DMA (33) on DVD-ROM drive
4) Swapping IDE cables, configuring drive as slave and master on IDE-2
5) Switching detonator drivers from 23.11 to 22.80
6) Changing AGP aperture size

I'm all out of ideas. Could you help?

-------------

SYSTEM

Athlon 1.2ghz (200mhz fsb)
Asus A7V-E mobo
Magico 12x DVD-drive
512mb Crucial Cas-2 RAM
Creative Geforce3 Ti500
Samsung SyncMaster 750s 17" Monitor
SB Live Platinum 5.1
January 13, 2002 12:48:09 PM

Forgot to mention:

In WinDVD, it makes no difference whether hardware acceleration is turned on or off. However, in PowerDVD the quality gets much worse if I turn it off, looking pretty similar to the way WinDVD looks all the time.

I figured it was a hardware acceleration fault in WinDVD, so I tried using DVD Genie to force it, but with no luck.
January 13, 2002 1:49:30 PM

Seems to me that you've pretty much covered all the bases! The problem might not be solved, but you've done a good job troubleshooting.

A few questions - (and bear with me, because you've probably checked the majority of this stuff already):

What is your operating system?

Is the video card set as AGP 4X in the BIOS? AGP Drive Strength on Auto? Fast Writes enabled? Aperture at 256? PIO and Ultra DMA Modes set correctly?

Video Memory Cache Mode set to UC?

Video ROM BIOS Shadow disabled?

Is the monitor driver installed? Color set at 24 or 32-bit?

Are all other unnecessary programs disabled when you run the DVD software player, such as an Anti-Virus?

Have you updated the firmware for the DVD-ROM?

No conflicts in the Device Manager? PCI Slot 1 free on the mainboard? (PCI cards in that slot share an IRQ with the video card.) In Win9x, only the IRQ Holder For PCI Steering can share an IRQ with the video card.

Do you see that same kind of problems when running 3-D games? If so, and if you are running Win9x, it's possible that you might have to adjust the vcache settings in the system.ini file.

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
Related resources
January 13, 2002 5:29:02 PM

Hi, thanks for the reply!

You mentioned a few things I'm not sure how to check, so I'll go through your questions in order.

1) My operating system is Win98, First Edition.

2) The card is set as AGP4x. Drive strength is on Auto (I tried setting it to E 7 with no change). Fast writes made no difference, and changing the aperture to 256 actually made it worse due to frequent pauses. What does PIO stand for? The drive is currently set to UDMA 2, which is its correct speed.

3) I tried setting the Video Memory Cache to UC and USWC, no change.

4) I don't know how to disable the video ROM BIOS - don't remember seeing an option for that in the BIOS.

5) Tried the monitor with the driver and with PnP - no difference. Changing colour depth also makes no difference.

6) I'm running a bare minimum system - only Explorer, Point32 (Intellimouse) and Systray are running at the same time.

7) Having trouble finding a firmware update for the drive. It's a Magico Star2000, and I'm having trouble finding any web sites for it.

8) The video card is not conflicting with any other device. However, there is a weird problem with my Soundblaster - something else called simply "PCI Multimedia device" gets detected, and there don't seem to be any drivers for it. This is the only out-of-the-ordinary thing on my device list.

9) 3D games run very clearly, but are somewhat slower than what I would expect from such a good graphics card.


Thanks for your advice. It's a real mystery what's causing this. Someone on another board suggested that it could be something to do with a high error rate on the DVD drive - do you think this could be the problem?
January 13, 2002 7:41:50 PM

you might try to rip the dvd to your hard drive, maybe the transfer from the drive is screwing things up a bit. its a little far fetched but you have tried every thing already. also another bone head question, have you tried more than one dvd?

i went to the tomshardware forums and all i got was this lousy signature.
January 13, 2002 9:12:53 PM

If you can't find a firmware update for the drive, then you might consider taking it back and buying a more user-friendly brand, such as a Pioneer, Lite-On, or an LG Electronics. I also found it difficult to find a website that might have an upgrade for your device, and I can usually find nearly <i>anything</i>. I did locate the drive specifications, in Japanese ... but no firmware.

I would suggest making a couple of changes in your system.ini file, just in case there is a problem with the size of your vcache. These settings will also add some additional performance to your system.

Go to Start/Run and type sysedit. In the [386Enh) section add these lines, exactly as written:

MinPagingFileSize=2048
MaxPagingFileSize=2048
ConservativeSwapFileUsage=1
PageBuffers=32

In the [vcache] section, add this line:

MaxFileCache=131072

Close the file, accept the changes and reboot.

Next, under My Computer/Properties/Performance/File System/Typical Role Of This Computer, choose Network Server.

In My Computer/Properties/Device Manager/System Devices/Direct Memory Access Controller/Properties/Settings/Reserve DMA Buffer, raise the KB setting to 64.

Do you have a Custom Swap File, or are you allowing Windows to control the Virtual Memory?

As for the sound card, I'd remove it from the Device Manager, and allow Windows to redetect the device. If the unknown PCI Multimedia Device re-appears ... see if you can download a newer driver set from <A HREF="http://www.soundblaster.com/drivers/" target="_new">Creative</A> for the card.

You should also check to see if the onboard audio is enabled in the BIOS. If it is ... disable it. That could interfere with the SoundBlaster card. Afterwards, remove it from the Device Manager.

A couple more questions:

Have you installed <A HREF="http://www.microsoft.com/directx/homeuser/downloads/def..." target="_new">DirectX</A>?

Have you checked your video hardware acceleration levels in My Computer/Properties/Performance/Graphics?

Oh, and by the way, there really should be a setting in your BIOS called Video ROM BIOS Shadow, and it should be disabled by default. I was checking out your mainboard <A HREF="http://www.asus.com.tw/download/manual/mb-man-other.htm..." target="_new">manual</A> when I posted this morning, and unless the BIOS version and settings have been radically altered ... it should be there.

Toejam31

P.S. Two things. In the Device Manager, under Creative Miscellaneous Devices /Creative SB16 Emulation/ Settings - check the option for LPT Interrupt Sharing.

PIO = Programmed I/O Modes. <A HREF="http://www.pcguide.com/ref/hdd/if/ide/modes_PIO.htm" target="_new">IDE/ATA Transfer Modes and Protocols</A>.

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
January 14, 2002 8:51:47 AM

I was not happy with the quality of dvd playback on a high quality monitor until I hooked up my computer up to a 32" tv and the picture looked great. The quality of dvds is not as good as you might think. Tvs hide a lot of flaws because of their relatively poor resolution. Monitors expose the weeknesses of the mpeg2 system. Keep in mind that a 17" monitor is looks twice as big visually at a normal computer viewing distance as a 32" tv looks visually at a normal tv viewing distance. You may need to fix the problem by lowering your expections.

Remember if you ain't Muslim you ain't Shiite.
January 14, 2002 7:21:56 PM

but it shouldnt look grainy...
i had a dvd rom in my old computer, and it was fine..the picture looked great....better than on a tv...
divx movies get grainey because they are ripped, and then compressed A LOT!....and the compresion kills the quality sometimes. unless you are a good dvd ripper, and know what you are doing.
if you arent using a dedicated dvd decoder card, then you are relying on your cpu to decode the information.
and since the drive is ide, that is taking cpu power too. so if you dont have a fast computer, you are going to be getting poor playback.
but you do have a 1.2 athlon...so that doesnt seem like it would be the problem.
i have no idea what is going on...


-DAvid

-Live, Learn, then build your own computer!-
January 14, 2002 8:03:39 PM

I've got access to 4 different computer dvd players. A cel 600 with pci decoder hooked to a sony professional 17" monitor, a cel 400 12" laptop with pcmcia decoder, a 15" p3 1G laptop with software decoding, and a p4 1.3G with an ATI AIW Radeon hooked to a samsung 700ift and a 32" tv. The 12 laptop is not big enough to show flaws so it looks fine ( and small), the 600 with the decoder looks blurry which eliminates any grainyness, the 15" laptop and the 17" 700ift look grainy. This grainyness is the same digiblock that shows up on mpeg4 divx downloads except that it is much finer and can only be seen for what it is if you freeze frame and blow up the picture. When you do that it looks just like a downloaded movie. The same picture that looks grainy on a 17" 700ift looks perfect on the 32" tv. I've not seen a dvd on a monitor that looks as good as I originally expected ever. We have an old monitor at work that does not get that bright and it looks better then my good monitors at home because it cannot expose the flaws. Could be all my systems are screwed up too but I doubt it.

Remember if you ain't Muslim you ain't Shiite.
January 16, 2002 7:46:20 PM

I've bought a new DVD drive, this time it's a Samsung SD616, which is a 16 speed UDMA-33 drive. To be honest, there's not much difference.

I had heard that there is some pixellation on DVD's, but the stuff I'm seeing is really nasty. Closeup detail is fine, but anything which is fairly dark or out of focus gets turned into big blocks which would be visible even if you were sitting 10 feet away. They don't even change rapidly, as you would expect if they were refreshed at 25 frames per second. Instead, the blocks hang there for about a second and then change. Maybe it happens to everyone though. It's particularly bad in Se7en and some parts of Alien, but it's there to some extent in all the films I own.

I'd certainly feel better (if a little disappointed) if these problems were common. It's a shame though, as I've heard so much raving about how DVD's give perfect picture quality. But I've tried tweaking everything, including all of the suggestions on this thread, so I suppose it's time to give up.

Thanks for your help, though. I feel like I know a lot more about how DVD's work.
January 16, 2002 11:53:23 PM

Sorry you have not had better luck. Try hooking up a tv to your computer if you can. The result will surprize you. The picture will look perfect like everybody says. DVDs use MPEG2 compression which works a lot like mp3 does for sound. Mp3 does such a good job compressing by throwing away what you can't hear. The sound might be in the original but mp3 tosses it out if it thinks you will not be able to hear it. Mpeg2 does the same for video. If it thinks you will not be able to see something it junks it. The result is that sometimes the algorithm isn't perfect and tries a little too hard to squash things. Are you watching in the dark? Turning a light on will lower the overall contrast ratio and actually make the movie look better. Turning out the lights will make the picture look worse.

I just had an idea! What color depth are you running? If you are running 16 bit that could cause a problem. Make sure you are running true color or 24bit.

Since the flaws are persistent, speed is not the problem. A 1x or 2x dvd player should be fast enough to play a dvd. The faster speed only matters on rips or software installs. A 95 minute movie is going to take 95 minutes to play if you have a 16x, a 12x or a 2x.

I've been doing mpeg4 conversions for a while and at first I thought the quality was near perfect even at a low quality setting. The 12" laptop I was using could not show the flaws. After doing the conversions for a while I started noticing more and more errors. I used to think my satellite had a perfect picture until I learned what to look for and now it looks like crap to me. My buddy Bill curses me for ever educating him as to the flaws cause once you see them you always see them. I "ruined" his satellite.

Remember if you ain't Muslim you ain't Shiite.
!