Sign in with
Sign up | Sign in
Your question
Solved

Geforce 550 ti quick question

Last response: in Graphics & Displays
Share
December 1, 2012 10:12:29 PM

Do you need to use the 4 pin to a 6 slot power cable? or could you just use a 6 slot straight from your PSU to power the card?
a b U Graphics card
December 2, 2012 12:26:22 AM

Well if the PSU does have a 6pin conn use that. If not use an adapter.

Btw what is your PSU ?
December 2, 2012 12:47:04 AM

Corsair cx 500w
Related resources
a b U Graphics card
December 2, 2012 10:32:26 AM

Well here it says it has 2x PCIe pins. So where are you using them lol
a b U Graphics card
December 2, 2012 10:34:19 AM

prototype18 said:
Well here it says it has 2x PCIe pins. So where are you using them lol

I think he is asking if the molex pin adapters are required (??)
a b U Graphics card
December 2, 2012 10:49:10 AM

Well he dont need the adapter if he has already the 2 PCIE
December 2, 2012 1:32:44 PM

i was just wondering, because my Gpu is having issues being recognized in my computer, so i was just wondering if that was the reason why.
a b U Graphics card
December 2, 2012 1:39:29 PM

That pin from the PSU is sufficeint (unless a cable is cut) .

That wouldnt be the problem .Uninstall old drivers and install new one.
December 2, 2012 1:41:00 PM

its a new PSU so i wouldnt think so, and where can you go to uninstall the old drivers?
December 2, 2012 1:41:06 PM

i don`t know my way around windows 7 that well o_o
a b U Graphics card
December 2, 2012 1:51:19 PM

Download driver sweeper and use it to uninstall the drivers
December 2, 2012 1:57:40 PM

okay thanks i did it, going to reset my computer with the 550 ti in
a b U Graphics card
December 2, 2012 2:01:51 PM

Remove Driver / turn off / install Gtx 550 ti / Turn on / Install Drivers/ Restard and come tell us here :) 
December 2, 2012 2:23:52 PM

nothing changed... my computer still doesn`t recognize the graphics card.
a b U Graphics card
December 2, 2012 2:52:23 PM

Can you try reset the bios ?

BTW what is your system. All the specs plz
December 2, 2012 3:08:25 PM

i already reset the bios, no help.
4GB (ram)
Pentium(R) Dual-Core CPU E5300 (processor)
Windows 64
MCP73VT-PM (motherboard)
cx500w (PSU)
NVIDIA Geforce 7050/NVIDIA nForce 620i
Bios AMI P01-A0
600gb memory DDR2

tell me if i missed anything
a b U Graphics card
December 2, 2012 8:20:43 PM

Well did you disable onboard video in the BIOS ?
December 2, 2012 8:36:58 PM

yes and changed it to PCIE
a b U Graphics card
December 2, 2012 8:48:50 PM

Can you try another GPU ? Just to test the mobo /card ?
December 2, 2012 9:06:18 PM

i tested my other GPU and it worked fine. im guessing the new GPU is dead (the 550)
a b U Graphics card
December 2, 2012 9:16:13 PM

Yes . Fill in the RMA :) 
December 2, 2012 9:17:07 PM

thanks a lot, ill get a refund from evga. whats the best card you think in your opinion for under $120?

Best solution

a b U Graphics card
December 2, 2012 9:19:24 PM
Share

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

The best ever in that price. Its GHz edition and it will OC like crazy. And its a very good one.

http://www.techspot.com/review/603-best-graphics-cards/...

check the games
a b U Graphics card
December 2, 2012 9:42:57 PM

No no no. That is not a compare. Listen me that 7770 is way better than 550ti
December 2, 2012 9:45:26 PM

okay thanks a lot! ^_^ i just placed an order, its hope this one isnt DOA like the last graphics card :) 
December 2, 2012 9:45:39 PM

Best answer selected by laxrules56.
a b U Graphics card
December 2, 2012 9:57:34 PM

Xd

Good Luck !
!