Help with HD7870, black screen

Hello,

Recently bought this card: http://www.amd.com/uk/products/desktop/graphics/7000/7870/Pages/radeon-7870.aspx

Trying to install to into my M4A785TD-V EVO:
http://uk.asus.com/Motherboards/AMD_AM3/M4A785TDV_EVO/#specifications

Currently having problems which have consumed most of my evening. I've installed the card into my x16 pci e 2.0 slot, powered it with the 2 cables provided. The fans spin and appears to be powered.

I however cannot get any display out of the card at all, I've tried on numerous different ports (hdmi, vga etc) but nothing at all, just a black screen. I've installed/reinstalled drivers countless times, even used the driver which automatically detects your model - for some reason it installs drivers for a hd4200 card?

Would anyone be kind enough to lend some insight?

Many thanks!
3 answers Last reply
More about help hd7870 black screen
  1. I guess your using your motherboards on board graphics in order get into your desktop and install these drivers. So when you use the auto detect option, it's going to detect the HD4200 (mobo).

    Go into your BIOS and find the option to select x16 PCI-E slot as your primary display.
  2. alexdh01 said:
    I guess your using your motherboards on board graphics in order get into your desktop and install these drivers. So when you use the auto detect option, it's going to detect the HD4200 (mobo).

    Go into your BIOS and find the option to select x16 PCI-E slot as your primary display.


    Ah, so it's detecting my onboard graphics

    Nothing else appears in my device manager in that case, cannot get my computer to detect it at all

    Any ideas? Been trying to sort this for hours
  3. Did u do as choose said, and switched from onbaord to pci-e in the bios? You cant switch from windows.
Ask a new question

Read More

Radeon Graphics