Sign in with
Sign up | Sign in
Your question

Crysis 2 and 3DMark won't start up

Last response: in Windows 7
Share
March 6, 2012 9:35:32 PM

Hey guys, I just bought a new Clevo P150HM about 2 weeks ago. Since then, I've played Shogun 2: TW (with DirectX 11 enabled), NFS: Hot Pursuit, Rage, Crysis, CoD: MW2 and Mass Effect all without problems. In the first couple of days, I also ran 3DMark06 and was able to go through the whole test without any problems.
Recently, I tried running 3DMark11 and for some reason, it wouldn't start. I'd see the little blue circle next to the mouse spinning a little bit and then it'd disappear and nothing would happen. A quick look in the Task Manager shows me that it's not running at all. I then tried PCMark Vantage and the same thing happened. Then I went back and tried 3DMark06 and the same thing is happening with that too now. I've tried uninstalling and reinstalling the programs as well as uninstalling my GFX card drivers as well as doing a Driver Sweep and then reinstalling the drivers but still the same thing. My games still worked fine though.
But now I've just installed Crysis 2 and it appears to be having the same problem. All my other games are working fine though. What could be causing this? I have DirectX11 installed as well as the latest Catalyst drivers installed. My specs are:

i7-2670QM
Radeon HD 6990m 2GB
16GB 1333MHz RAM
500GB 7200RPM HDD
Windows 7 Ultimate

Thanks a lot guys and I really hope I wouldn't have to reinstall windows coz it took me ages to get everything set up and that was less than 2 weeks ago!

More about : crysis 3dmark start

March 7, 2012 5:23:13 AM

no suggestions? If this is in the wrong forum then could someone please point me in the right direction? I'm still new here :) 
March 7, 2012 9:11:35 PM

Just a little update. I've just reinstalled Crysis 2 but this time without the DirectX11 patch and it's working perfectly. So I guess this isolates the problem somewhat. Does anyone have any suggestions as to how I can proceed? I would really like to enable the DX11 features.
!