Sign in with
Sign up | Sign in
Your question

My samsung laptop isn't using my AMD Radeon HD7550M 1GB

Last response: in Graphics & Displays
Share
December 3, 2012 6:13:14 PM

Hello all,

I cant get my video card on my laptop to actually work to play games... I tried configuring swtichable graphics from the amd software, but nothing seems to change. So now its running on the intel graphics, wich kind of sucks since i chose this laptop for the graphics card to give it a little more punch when i play video games. mostly sc2.

Could anyone help me in resolving this issue ?


Many thanks



laptop : Samsung series 5

Intel® Core™ i5 Processor 2467M (1.60 GHz, 3 MB L3 Cache)
AMD Radeon™ HD7550M Graphic Memory 1 GB DDR3 (Ext. Graphic)
6 GB DDR3 System Memory at 1333 MHz (on BD 4 GB + 2 GB x 1)
a b U Graphics card
December 3, 2012 6:23:52 PM

You should be able to manually set it in BIOS (disable the intel adapter perhaps).

You should be able to use Gpuz (or some hardware monitoring program) to confirm which GPU is running, a 7550 isn't exactly going to be a gaming powerhouse, I wouldn't be surprised if the two GPUs are fairly close in performance.

m
0
l
December 3, 2012 6:50:35 PM

When i disable the intel graphics, the comp doesnt switch to GPU and says i have an openCL bug... Anything i can do here ?
m
0
l
Related resources
a b U Graphics card
December 3, 2012 7:30:37 PM

How do you know it has not switched to the GPU? The GPU isn't that great, so if you say that because you still get bad framerate in SC2,your expectations may be the issue.

Where do you get an OpenCL bug? OpenCL isn't required to use your computer. Unless you give useful and descriptive info, you can't expect useful help.
m
0
l
a b U Graphics card
a b D Laptop
a b À AMD
December 3, 2012 7:31:24 PM

Does you latop use lucid logic gpu switcher?
m
0
l
a b U Graphics card
a b D Laptop
December 3, 2012 7:43:43 PM

SEE: http://www.notebookcheck.net/AMD-Radeon-HD-7550M.70625....
Scoot to the bottom where it shows gmes and you will see many are "not Playable" and several that show Low FPS with LOW setting.

As stated, if you down load GPU-z you shoud see that for 2D apps it should show the Intel dGPU then when you run a 3D app it should switch to the dGPU, download and run Furmark in a window to verify.

If it does not switch I'd take a long hard look at the drivers, Both the Intel and AMD and make sure tey are up to date. While checking, also verify your laptop is running the latest Bios version. Often people Buy laptops and Never update their Bios.
m
0
l
December 3, 2012 7:53:51 PM

I check using GpuZ, and when i run a game it stays on the integrated graphics, im going through the process of checking all my drivers, hope it helps.
m
0
l
December 3, 2012 8:19:19 PM

Also, when i check GPUZ i have the option to switch between integrated graphics but in catalyst control center i can only see intel integrated graphics, and when i run a game it stays on the integrated graphics....something is weird here

Please help !! :) 
m
0
l
a b U Graphics card
a b D Laptop
December 4, 2012 1:38:38 AM

Sounds like the problem is with your CCC.
Could also be a problem in the Registry. ie if you have upgraded AMDs catalyst and video drivers without properly removing the old driver you can end up with old entries in the registry.
To check this:
1) remove driver and amd Video software, reboot to default VGA , run driver cleaner (ie CCleaner, a free download). Then reinstall amd's driver and Catalyst software.
m
0
l
a c 109 U Graphics card
a b À AMD
December 4, 2012 1:39:52 AM

12.11 drivers?
m
0
l
April 13, 2013 9:57:26 PM

bjsm said:
Hello all,

I cant get my video card on my laptop to actually work to play games... I tried configuring swtichable graphics from the amd software, but nothing seems to change. So now its running on the intel graphics, wich kind of sucks since i chose this laptop for the graphics card to give it a little more punch when i play video games. mostly sc2.

Could anyone help me in resolving this issue ?

Many thanks



laptop : Samsung series 5

Intel® Core™ i5 Processor 2467M (1.60 GHz, 3 MB L3 Cache)
AMD Radeon™ HD7550M Graphic Memory 1 GB DDR3 (Ext. Graphic)
6 GB DDR3 System Memory at 1333 MHz (on BD 4 GB + 2 GB x 1)



bjsm here is your solution....
i too had the same problem with amd graphic cards
1. go to catalyst control centre (right click on desktop and select graphic properties)
2. now go to gaming tab and under that click 3D application settings
3. here uncheck the "use application settings" under the section "anti-aliasing" and "anisotropic filtering"
4. now choose the level under both these section to 4X and select the filter under "anti-aliasing" section as "edge-detect"
5. now click the "save" button on top and a dialog box will appear, here choose the launch file of the game of your choice(.exe file) and click open
6. what happens is that the game is saved as a profile in your catalyst control centre, that is with your amd graphic card, as a result the game would only b played using amd graphics
7. now right click your game launch file (.exe file) and click run as administrator
7. do this for every game you want to play with amd graphic card
8. enjoy ! :) 
m
0
l
August 12, 2013 4:51:59 AM

what display driver your system is showing ?

Also, don't uninstall drivers yet. Things can get very tricky if you miss any step and you will have to re-install windows.
m
0
l
!