Sign in with
Sign up | Sign in
Your question

Nvidia Drivers Stopped responding for Far Cry 3

Last response: in Graphics & Displays
Share
a b U Graphics card
December 3, 2012 8:46:54 PM

Hi Guys,
So after a long wait Far Cry 3 comes out, and to my dismay I can only play it for 5-20 minutes before the game crashes. I have it fullscreened and couldnt work out what was going on, as it just shows the desktop instead when it crashes.

Eventually I tried it in windowed mode and when it crashed a pop up said Nvidia drivers have stopped responding and recovered. I have searched that message and most are having hardware issues or PSU problems. This is the first time this is happened on my system. Everything works fine still after closing the game off.

I have updated my drivers to the beta ones, (310.64 i think it was) which has far cry 3 support. I also updated the game with the day one patch and put all settings to low but it doesnt make a difference.

Im pretty stuck here guys, any ideas?
My system is listed in my sig.
a b U Graphics card
December 3, 2012 9:09:28 PM

Have you OC it?
a b U Graphics card
December 3, 2012 9:15:27 PM

The GPU or CPU?

I did a mild OC for the CPU, just a bios option but i went back to stock speeds and still had the problem.

The GPU is factory overclocked. Should I try lowering the clock speeds or something?
Related resources
a b U Graphics card
December 3, 2012 9:58:25 PM

I had a look over that, I will try the other slot when i get home but I cant seeing it make a difference. The reason I say this is that the guy on the other thread was always having the issue, whereas mine only does it in this one game. It has been fine for the few months Ive had it in there, and now only has the issue when the game is running.
a b U Graphics card
December 3, 2012 10:01:11 PM

Burgies said:
I had a look over that, I will try the other slot when i get home but I cant seeing it make a difference. The reason I say this is that the guy on the other thread was always having the issue, whereas mine only does it in this one game. It has been fine for the few months Ive had it in there, and now only has the issue when the game is running.

Ahh... Yes I remember I had the same problem with my gtx 560.

Go to the nvidia control panel and disable the sound drivers in it (from HDMI, there is sound so there will be drivers for it) I forgot how to though...
a b U Graphics card
December 3, 2012 10:05:37 PM

Interesting solution, i dont see what difference it could make but its such a random problem that it really could be anything :p  Ill give it a shot later.

If anyone else has any ideas to try ill give them all a go one at a time.
a b U Graphics card
December 4, 2012 12:33:00 AM

Just had another thought, could there be any benefit in changing the ingame settings to direct x 9 instead of 11?
Anonymous
December 4, 2012 12:36:03 AM

My question is how are you playing it when its not even releasing until tomorrow the 4th?
a b U Graphics card
December 4, 2012 12:39:31 AM

Im in Australia, released a fair bit earlier everywhere else besides North America. It looks great but pretty frustrating having it drop out every 5 minutes.
a b U Graphics card
December 4, 2012 4:20:24 AM

Burgies said:
Just had another thought, could there be any benefit in changing the ingame settings to direct x 9 instead of 11?

Very Unlikely, but you can try ;) 
a b U Graphics card
December 4, 2012 4:22:59 AM

So i went into nvidia controls and disabled the audio feed on my hdmi output, thats the only thing i could see and it still crashed.
a b U Graphics card
December 4, 2012 6:02:47 AM

So I went through all that, and then the drivers failed to install. I restarted it and the computer automatically installed drivers. The game still crashes....
a b U Graphics card
December 4, 2012 8:16:41 PM

So i tried something that I think has solved the issue. Ill post it in the hope it helps someone else that has this problem.

All I did was use MSI afterburner to turn my clockspeeds DOWN by 50. Thats it and the game has still run on ultra smoothly. Some cut scenes get a little choppy but ingame is great. My guess is that this is the first time my 670 has run at max for any amount of time, and possibly with MSI turning off voltage options it wasnt getting enough power for the speeds it was at. Any thoughts on this guys?
December 4, 2012 8:26:41 PM

I was playing that game all day Today with my MSI GTX 670 PE. I haven't had a crash. I would sweep my drivers after an uninstall then install 310.64 again. The game seems to run around 60FPS with everything maxed out besides MSAA I have that on 4x.
a b U Graphics card
December 4, 2012 8:38:36 PM

Last time i tried that the pc automatically installed drivers, which I didnt want it to do, is there any way to cancel that?
December 4, 2012 9:50:03 PM

It sounds like windows is installing the basic driver set not the Homepage drivers.
a b U Graphics card
December 4, 2012 9:51:44 PM

Either way im running 310.64 now, and the change to clock speeds fixed my issues. I might just leave it for now, so i can actually play :p 
December 5, 2012 12:07:30 PM

I have Nvidia GTX 480 with the same issue, but i played untill the 3d mission of Hoyts Island without problems besides some low screen bugs, but now the game is randomly crashing between 2 second to 10 minutes, i also tryd lowering clock speed with 50 but gues what... still crashing. i installed the 310.70 beta driver wich does better than the previous WHQL driver. but i cant escape crashing. I play every game wich is out today without problem but Far Cry 3 is the first one wich gives this kind of a error.
System specs are:

Asus P6X58D-E Motherboard
Intel i7 950 3.2 Processor
Nvidia GTX 480 Grapichcard
6GB DDR3 Kingston Hyper-X Ram
Windows 7 Ultimate x64

[SOLVED] Like Burgies already said, very simple things can cause crash problems, mine was that the fans of my videocard, motherboard etc were full with dust and needed to be cleaned, Open up your pc and clean up the dust in your hardware.
a b U Graphics card
December 5, 2012 8:35:36 PM

Good to see that you got your issue worked out. Good airflow is often forgotten. Maybe Far Cry 3 is the first demanding game in a while so peoples machines are struggling without the maintenance.
!