Sign in with
Sign up | Sign in
Your question

HIS HD 6770 issue

December 4, 2012 7:24:57 AM

Hi guys,
I've been here a lot lately, but always read stuff, never wrote here. I had an ASUS HD5750 card which was performing incredibly (the stock cooler allowed me for a few more MHz) until the new Need for Speed came.
I struggled a lot, but no matter what I did it always stayed at constant 18-20 FPS. Anyway, I thought I'd get a second 5750 to crossfire as the budget didn't allow for a brand new faster GPU (and to be honest, if it works anywhere else, why should I throw it away?).
I found this HIS HD 6770 (used, but under warranty) which was cheaper than any 5750. I crossfired, some stuff got faster, some didn't (hate NFS now). Anyway, the problem is that when I turn PC on it wil buzz like crazy. Really loud like the fan is out of its bearing or something. I took it aoff (the whole cooler little plastic case), reapplied thermal paste on my way and connected again, but still nothing.
It happens, like 4 out of 5 times. If it buzzes, I hold the power until PC dies (still within BIOS of course) and try again until it starts quietly. Another thing is that when i press the fan gently (during the startup buzzing) it stops, starts again and works nice (even if I play games, stress GPU and do whatever graphic-related). It speeds up as it should, it slows down as it should.
I'm not the instant-replace kind of guy so I was wondering if anyone has ever encountered something like this. Maybe I need to take the cooler itself apart and tighten something loose there? Any ideas?
Thanks in advance, sorry for the long post.

More about : 6770 issue

!