Sign-in / Sign-up
Your question

High fps graphics

Tags:
  • Graphics Cards
  • Graphics
Last response: in Graphics Cards
December 4, 2012 10:48:36 AM

Hello,

Im playing Trackmania Nations Forever at a high level and just want HD resolution and max framerate without stuttering.

Shadows, smoke, clouds, water and such is not interesting.

Decent texture quality, 4-6xAA and HD res.

I had a GTX260 card that worked good, 120-200fps with my settings but it crashed.
The gtx260 was also loud and got hot.

I have a Radeon 5850 now and it will only go between 80-120fps with the same settings.
I know some might not believe me, but i can tell the difference.

I tried a Radeon 7850 OC, but it was worse performing than the 5850 and I also got artifacts.

I want a quiet, low power consumption card that can give me no lower than 120fps+ at all times, what should I buy?

More about : high fps graphics

a c 94 U Graphics card
December 4, 2012 11:51:28 AM

sound like your cpu might be bottleneck. what the full computer spec?
December 4, 2012 11:57:11 AM

CPU: AMD phenom X4, 2.2Ghz (i think, it was a while since i bought it)
PSU: Corsair 850W (I know thats overkill)

Since the GTX260 worked pretty good (except that I want a bit more performance and less noise), how can the CPU be the problem?
Related resources
Can't find your answer ? Ask !
a b U Graphics card
December 4, 2012 3:36:35 PM

well get a GTX 670 or a 7950, but since u want to go at 200 FPS,
do u even have a 120 fps monitor to start with?
and even if u have that, u DEFINATELY dont own a 200Hz monitor.

According to me your quest to get a 200 FPS is a Fool's errand,
the difference between 60FPS and 120 FPS is slightly noticable sometimes,
but i dont think u can even see a slight difference between 120 and 200FPS.
a b U Graphics card
December 4, 2012 3:45:45 PM

If you don't have a 120Hz monitor then anything over 60 fps can't be displayed anyway... I think you should look into a new CPU over a GPU, that is most likely your bottleneck. And did you have something monitoring your FPS or are you just guessing at the FPS you were getting based off of the smoothness?
a b U Graphics card
December 4, 2012 3:48:41 PM

dheeraj9933 said:
well get a GTX 670 or a 7950, but since u want to go at 200 FPS,
do u even have a 120 fps monitor to start with?
and even if u have that, u DEFINATELY dont own a 200Hz monitor.

According to me your quest to get a 200 FPS is a Fool's errand,
the difference between 60FPS and 120 FPS is slightly noticable sometimes,
but i dont think u can even see a slight difference between 120 and 200FPS.



IMO, and a lot of articles (unfortunately not proven since everyone's eyes are different) But a human can't even see over 15 frames per second.. It only looks fluid after that because were seeing every other frame etc. So the difference in 40 ~ 60 frames per second. Is nothing. People think they see a difference. But it's not really there. Ive seen some funny articles where people think the 30 fps is the high one and the 70 fps is the slow and dragging one :p . When you don't see the actually fps proof in your face it's extremely hard to tell a difference. Now that ive ranted...

@OP dheeraj9933 is right. It's a fools errand and for nothing but "bragging rights" you or no one else can see over 50 fps :D .
a b U Graphics card
December 4, 2012 3:54:37 PM

You really need to shoot for constant FPS not extremely high FPS... if you can put on vsync to cap your fps to 60 you should see a big difference in the "smoothness" of the game. Its the changes in FPS that makes things look bad, weather its the sudden drop from 180 fps to 100 fps or the change from 60 to 40... Its the changes that you can see. So try capping your FPS to 60 and try that out.

Not only will things look better, you will put a lot less stress on your video card, and save power!
a b U Graphics card
December 4, 2012 4:32:03 PM

Agree with everyone here. If you were running at 200FPS that is why your GTX260 got loud and hot, and probably why it died.

Enable vsync, and cap your framerate at 60fps (assuming you have a 60hz monitor and not a 120hz monitor). It is literally (I mean absolutely) impossible for you to see a smoother image by rendering more frames than your monitor can display.

When your GPU draws a frame, it gets stored in graphics memory. When your monitor is ready to show a new image, it sends a signal to the graphics card, causing it to send the contents of the frame buffer in graphics memory to the monitor.

When you have vsync on, the GPU will draw a frame, wait (idle) for the monitor to request a frame, then send it over and begin drawing the next frame. This will keep you at 60fps, and allow your card to run only when it needs to (in your case around 50% or less utilization), and prevent it from doing extra work. (It attempts to draws 1 frame for every refresh of the monitor)

If you disable vsync, instead of waiting for the monitor to use the frame that it drew, it immediately starts drawing another frame. If the frame finishes before the monitor draws the current waiting frame, it gets overwritten with the new frame, the old frame never gets displayed and just disappears. This also allows for a 'tearing' effect to occur, in cases where the card is half way through the process of sending a frame to the monitor, and a new frame finishes drawing, and replaces the image being sent half way through the transfer, causing you to have the top of one frame and the bottom of another. Your GPU will always run at 100% (assuming it's not limited by the CPU), and will get very hot, but most of the work gets thrown away (because you render two frames for every frame the monitor uses).

The reason to turn vsync off is when you are not getting 60fps, you want your GPU to render as much as it can in order to give smoother framerates, rather than sitting idle and waiting for each frame to be called up by the GPU.

(Note: In reality, the framebuffer will store 2 or 3 frames, not just one, but the effect is the same, 2 buffers are used so that the gpu can draw a scene (a multi-step process) to one buffer while the monitor reads from the other buffer, when the scene is done (or the frame is sent to the monitor) the buffers swap, and the monitor reads from the just completed scene, while the GPU draws to a the just sent buffer, a 3rd buffer is sometimes used to smooth out any momentary dips in fps).

December 5, 2012 4:58:50 PM

Hi, thx for your answers.

My monitor is a Samsung BX2431 with 2ms response and 60Hz.

Well, if its not the framerate that is the problem then I dont know what is.

I have now tried to activate the Vsync but the framerate numbers given ingame still remain between 70-120fps.
I tried to increase AA from 4x to 8x but the framerate still remain the same - except that I saw glitches of the backround looking a bit strange at times.

Personally I think that the AMD VECC sux, it seems that whatever I do with it nothing really happens.

Maybe its just something in the nvidia system that works better with this game and maybe the fps numbers given ingame are totally nonsense.
Cuz I KNOW that the game looked smoother and never had any lag whatsoever when the ingame framerate always hoovered above 120fps at all times.

a b U Graphics card
December 5, 2012 5:24:50 PM

Try using Fraps to monitor your framerate, it maybe that the framerate measurement in game is not truly framerate, but some other metric. Otherwise it maybe that vsync is not implemented properly in game (or perhaps you have forced vsync to be disabled in catalyst control center), try forcing vsync enable in catalyst.
a b U Graphics card
December 5, 2012 5:48:51 PM

gswe81 said:
Hi, thx for your answers.

My monitor is a Samsung BX2431 with 2ms response and 60Hz.

Well, if its not the framerate that is the problem then I dont know what is.

I have now tried to activate the Vsync but the framerate numbers given ingame still remain between 70-120fps.
I tried to increase AA from 4x to 8x but the framerate still remain the same - except that I saw glitches of the backround looking a bit strange at times.

Personally I think that the AMD VECC sux, it seems that whatever I do with it nothing really happens.

Maybe its just something in the nvidia system that works better with this game and maybe the fps numbers given ingame are totally nonsense.
Cuz I KNOW that the game looked smoother and never had any lag whatsoever when the ingame framerate always hoovered above 120fps at all times.

what card do u hav now?
7850 or 5850 ?
ther could be driver issues too, and the nvidia card was a old card, sometimes they work better in old games.
but still i recommend u use fraps to see exactly what's going on.
and have u updated the drivers? could be overheating too!
December 5, 2012 7:29:56 PM

About the "Vsync", I have set the "wait for vertical refresh" option as "always on"

I use the 5850 card.

I dont have any driver issues or overheating, such problems would be vastly bigger than mine.

Im just very picky and want absolute smoothness and and never wanna miss a frame, thats all.

I will try fraps tomorrow.
December 5, 2012 7:37:07 PM

I wanna add that 99% of all gamers would probably say that all looks perfect on my screen, im just very picky thats all ;) 
a b U Graphics card
December 5, 2012 7:39:01 PM

gswe81 said:
I wanna add that 99% of all gamers would probably say that all looks perfect on my screen, im just very picky thats all ;) 


Its your FPS fluctuation that is causing your problems, get your vsnyc issue worked out and you should be golden.
a b U Graphics card
December 6, 2012 2:16:04 AM

gswe81 said:
About the "Vsync", I have set the "wait for vertical refresh" option as "always on"



disable that
December 6, 2012 5:49:33 AM

OK, but I cant find something called "V-sync" in AMD VECC, "wait for vertical refresh" was the closest option.

Where do I find it? (screenshot would help)
a c 93 U Graphics card
December 6, 2012 6:13:01 AM

vertical refresh is vsync.

Always wait for vertical refresh should be on.

Override your game settings.
a b U Graphics card
December 6, 2012 7:19:50 AM

esrever said:
vertical refresh is vsync.

Always wait for vertical refresh should be on.

Override your game settings.

vsync should only be on if FPS go over 60 or 120 according to the monitor,
otherwise it does not help.
if u see stuttering of any kind due to low fps u should disable vsync
a b U Graphics card
December 6, 2012 1:12:04 PM

gswe81 said:
OK, but I cant find something called "V-sync" in AMD VECC, "wait for vertical refresh" was the closest option.

Where do I find it? (screenshot would help)


Vertical refresh is vsync. Right now, your game being at 120+ FPS indicates that vsync isn't working properly in the game; you're card is powerful enough to run at 60fps, which is the most you will be able to see on your monitor, so you should enable vsync.

If vsync is an option in your game, enable it there as well; and set it to be either "Application Settings" or "Always On" in AMD Catalyst Control Center (if it's already set to "always on" try putting it at "application settings"). You really want to limit your framerate to your refresh rate, as it will keep your card cooler/quieter, it may prevent anomalies you could be seeing from running at excessive fps levels (jagged edges in images for example)

a c 93 U Graphics card
December 6, 2012 5:14:06 PM

dheeraj9933 said:
vsync should only be on if FPS go over 60 or 120 according to the monitor,
otherwise it does not help.
if u see stuttering of any kind due to low fps u should disable vsync

did you even read the thread?
December 6, 2012 5:37:15 PM

I found V-sync hidden in the game settings and activated it, all is good now.

Thx for the help all, I dont need a new card, I just needed V-sync :) 
a b U Graphics card
December 6, 2012 5:43:50 PM

gswe81 said:
I found V-sync hidden in the game settings and activated it, all is good now.

Thx for the help all, I dont need a new card, I just needed V-sync :) 


Told you so! :kaola:  lol happy that eveything worked out for you :D