Sign in with
Sign up | Sign in
Your question

[6870] Graphics Failure with Need for Speed: Most Wanted 2012

Last response: in Graphics & Displays
Share
December 4, 2012 1:40:34 PM

Hi,

I am having strange issue with my graphics card when playing Need for Speed: Most Wanted 2012. Almost randomly after a while I am playing, during a loading sequence the screen can just go black, and it is happening consistently. My display's back lighting also fades.

The computer becomes unresponsive and I have to turn it off via the button. The last system information event I got during my last crash was "The Application Experience service entered the stopped state." Which to my eyes means nothing.

The card can handle the game fine, I don't get any frame rate drops and the temperature stays around 65ºC. I have downloaded the latest drivers (and beta drivers) and reinstalled Origin. I tried running it in a 1280x720 window mode but it still occurs, nothing has worked.

The main thing I want to deduce here if it is driver or hardware failure.

Thanks!

PC Specs

Graphics Card
Powercolor 6870

Processor
Intel Core i5 2500

Motherboard
ASUS P877 M-Pro

RAM
8GB
a b U Graphics card
December 4, 2012 1:50:07 PM

My friend with a 6870 plays it on Best possible settings.
a b U Graphics card
December 4, 2012 2:05:20 PM

What temp monitor did you use? Use SpeedFan to monitor your temperatures while gaming and report them back to us.
Related resources
December 4, 2012 2:17:50 PM

When I tested with GPU Temp I was in a 720 window.
I just did a few races with SpeedFan in a 1080 window and the entire time the temperature didn't go above 72ºC.
December 4, 2012 2:36:01 PM

Update
I was mid looking at map and it froze, screen filled with red and white lines.
February 2, 2013 11:25:53 AM

caboose221 said:
Hi,

I am having strange issue with my graphics card when playing Need for Speed: Most Wanted 2012. Almost randomly after a while I am playing, during a loading sequence the screen can just go black, and it is happening consistently. My display's back lighting also fades.

The computer becomes unresponsive and I have to turn it off via the button. The last system information event I got during my last crash was "The Application Experience service entered the stopped state." Which to my eyes means nothing.

The card can handle the game fine, I don't get any frame rate drops and the temperature stays around 65ºC. I have downloaded the latest drivers (and beta drivers) and reinstalled Origin. I tried running it in a 1280x720 window mode but it still occurs, nothing has worked.

The main thing I want to deduce here if it is driver or hardware failure.

Thanks!

PC Specs

Graphics Card
Powercolor 6870

Processor
Intel Core i5 2500

Motherboard
ASUS P877 M-Pro

RAM
8GB




I'm having similar issues wit my RIG and Game but it will freeze after it loads or just before a race...
Specs for my RIG:
ASUS Rampage IV Extreme BF3 Edition.
Intel Core i7 3930K
Corsair Vengence 2133MHz 32GB
ASUS ENGTX660 Ti DC2O
OCZ SSD 240GB x3 Raid 0
Thermaltake Grand Power 1200w
February 2, 2013 11:46:54 AM

Hey shmcphrsn,

I tried a few things to fix my graphics card and ended up getting an RMA on it over the Christmas break, so it took forever.

I recently got my replacement card, and have tested it out on Need for Speed. From the hours I have played the problem has been fixed.
Before getting an RMA I tried increasing fan speed, monitoring temperature, and completely uninstalling and reinstalling the drivers. I also tried playing with another graphics card, which solved the problem.

Getting an RMA might be the best route, if you have exhausted all other possibilities.

Hope this helps.

!