Sign in with
Sign up | Sign in
Your question

Please help, new rig hitching in all games

Last response: in Graphics & Displays
Share
December 4, 2012 4:17:18 PM

I just put together a new computer and am getting hitching in all the games I've tried.

Specs:
i7 3930k
ASRock Extreme6
32GB (8x4GB) Corsair Vengeance
EVGA GTX 680 SC 2GB
Samsung 840 250GB SSD
Corsair HX650 PSU

In Far Cry 3 I get hitches when looking around in different directions.
In Planetside 2 I get hitches when looking in different directions and when scoping with a sniper rifle. Seems like when it's rendering new terrain.
In CS:GO I get hitches in almost every engagement, when there are players on screen and they are shooting. Lowering my graphics made it a little better but didn't fix it.

Other info:
Have all drivers for mobo installed
Running 310.64 Nvidia drivers
Problem happens with default settings and with overclock

If anyone has any ideas I'd greatly appreciate it. This is extremely frustrating.

More about : rig hitching games

a b U Graphics card
December 4, 2012 4:20:43 PM

GPU/CPU temp ?
m
0
l
December 4, 2012 4:36:47 PM

CPU idling at 27 C right now. Highest I've seen it get is around 50C. Using Zalman CNPS9900.

GPU idling at 29C right now. I set the fan curve so it never gets above 70C.

m
0
l
Related resources
a b U Graphics card
December 4, 2012 4:43:25 PM

Well uninstall drivers and insatll non beta ones. And did u do a clean install ?
m
0
l
December 4, 2012 4:56:04 PM

Yeah it was a new hard drive. I'll try WHQL drivers now.
m
0
l
December 4, 2012 5:21:31 PM

Still the same problem with different drivers. I also tried disabling XMP 1.2 and using standard RAM settings, didn't fix it either. Thanks for your input so far prototype.
m
0
l
a b U Graphics card
December 4, 2012 5:24:27 PM

Well . New drivers release 310.70.

If they dont work too try using another card ?

Edit : Clock speeds on GPU ?
m
0
l
a c 106 U Graphics card
December 4, 2012 5:54:13 PM

try running with 2 sticks of memory.

monitor size/res ?
m
0
l
December 5, 2012 5:40:04 PM

Disabling speed step seems to have fixed it. I think it might have been actually caused by turbo boost and not speed step but that is disabled as well now.
m
0
l
!