Sign in with
Sign up | Sign in
Your question
Closed

New XFX 7970 Ghz card getting erratic FPS and glitching

Last response: in Graphics & Displays
Share
December 6, 2012 3:42:41 AM

Hello, First post here, only joined for this issue. I just Purchased a new XFX 7970 Ghz graphics card (see here: http://ple.com.au/ViewItem.aspx?InventoryItemID=610166 )
And i've installed it, and updated all drivers correctly (im pretty sure). The first game i tried, Assassins Creed 3, i noticed it lagged and there was the occasional stutter. In game, My fps ranges from 20, to a max of 60. i lowered the settings to the lowest, and that reduced it, but considering i just paid almost $500 for a graphics card, i'd want to run it at max. When i do so, and activate Anti-aliasing to max, this happens ( http://imgur.com/XlmEz ) I just upgraded from a AMD 6950.
My current specs are:
AMD Radeon HD 7970 3gb
Intel i7 960 3.20GHz
20gb RAM 1600 (you read right)
Antec 200 tower
Asus P6x58D-E mobo
24" BenQ xl2420t Running at 1920x1080 120hz
Any help would be greatly appreciated.

*Edit* If you know the game, the entire time i am in Boston, i get between 15 and 30 FPS
December 6, 2012 5:22:13 AM

looks like the card is damaged man, what temps are you getting from it?? From a 7970 GHZ edition you should be seeing much higher fps than that. 20% of the time its just a shitty hdmi/dvi cable, so you could try changing that around. Does this happen in any other game?? You could also try running anti aliasing using catylst control center and see if you get the same results. I remember i was getting stuttering and glitchy screen in skyrim when AA was turned up all the way. Might just be the game.
a b U Graphics card
December 6, 2012 5:34:35 AM

Try another game other than AC3, and post your findings here. Might be the game, newly released games (Especially console ports) can be glitchy.

What is your power supply?
Related resources
December 6, 2012 5:48:41 AM

azed3000 said:
looks like the card is damaged man, what temps are you getting from it?? From a 7970 GHZ edition you should be seeing much higher fps than that. 20% of the time its just a shitty hdmi/dvi cable, so you could try changing that around. Does this happen in any other game?? You could also try running anti aliasing using catylst control center and see if you get the same results. I remember i was getting stuttering and glitchy screen in skyrim when AA was turned up all the way. Might just be the game.


Thanks for the reply, The DVI cable is not the issue, i've swapped it out. Im not exactly adept in the use of CCC, so im not sure what you mean in regards to 'running anti aliasing using catalyis control center'
I shall try Far Cry 3, and Let you know the results.

@JJ1217 - My power supply is a 650w, not sure of the brand right now and it's difficult to check due to PC placement. Ill try Far Cry 3 or Bf3
a c 92 U Graphics card
December 6, 2012 5:57:21 AM

check temps.

also do a clean reinstall of the drivers. If that does fix it, might be a broken card.

power supply could be an issue if its a cheap no name brand.
December 6, 2012 6:20:57 AM

make sure vsync is off...
December 6, 2012 6:21:05 AM

Idling, the temp is about 38C, and when running Far Cry 3 at about 75% load it reaches 69C. In regards to FPS, in Far Cry 3, getting a pretty stable 30FPS ._.
a c 92 U Graphics card
December 6, 2012 6:27:00 AM

It should be getting higher. Reinstall the drivers. Remove all drivers first and install the latest ones.
December 6, 2012 6:32:37 AM

esrever said:
It should be getting higher. Reinstall the drivers. Remove all drivers first and install the latest ones.


Yeah, i've done this numerous times, to no effect.

Edit* I turned AA off, and the FPS has gone up to a stable 60.
a c 92 U Graphics card
December 6, 2012 6:36:22 AM

Is it only the AA?
December 6, 2012 6:39:23 AM

esrever said:
Is it only the AA?


Im sorry? im not sure what you're asking. Is what only AA?
a c 92 U Graphics card
December 6, 2012 6:39:52 AM

only AA that causes the problem?
December 6, 2012 6:43:25 AM

esrever said:
only AA that causes the problem?


In AC3, even with AA at the lowest setting 'Normal' you can't turn it off from what i've seen, perhaps just not from in game. But even with it at the lowest setting, It lags a lot.

Best solution

a b U Graphics card
December 6, 2012 7:19:14 AM
Share

I had similar problem with my HD 7870 but since i've downloaded the AMD Catalyst 12.11 Beta , the frame rates improved much.

Worth a try.
December 6, 2012 7:59:07 AM

ttcboy said:
I had similar problem with my HD 7870 but since i've downloaded the AMD Catalyst 12.11 Beta , the frame rates improved much.

Worth a try.


Could you or someone provide a link to the 12.11 Beta?
Thanks
December 6, 2012 8:07:29 AM

Under ccc, just click advanced tab and then the games tab, you should see a few settings for games, scroll down to Anti aliasing and make sure its on use application settings. You can also try closing ccc in task manager and running the game to see if theres an fps difference.
a b U Graphics card
December 6, 2012 8:13:10 AM

That glitch that the OP is getting when using the Very High AA setting is the same as what I get. This is NOT just his own card, this is a game/driver issue. Haven't tried out the new 12.11 Beta 11 driver with it yet, might have fixed it.

BTW, the Very High AA setting uses a combination of 4xMSAA and MLAA on ATI cards, on Nvidia cards it uses TXAA.
December 6, 2012 8:51:51 AM

Okay, I've now installed the 12.11 Beta driver, and the AA glitch in AC3 has been fixed! However, im still only getting about 30ish fps while in Boston, and slight lagging. Although 60 fps during loading.
December 6, 2012 9:42:21 AM

Best answer selected by 40 Cal Banana.
!