Sign in with
Sign up | Sign in
Your question

Black shadows around 3d objects in games. Is that normal?

Last response: in Graphics & Displays
Share
December 6, 2012 9:35:18 PM

I just bought myself a new PC with a NVIDIA 670 GTX and for the first time I'm playing in Direct X 11.

Graphics are great, fps is great, but I noticed in several games, including BF3, The Witcher 2, and Far Cry 3, characters and other 3d objects like chairs for example, are surrounded by a black shadow effect. Like if I added a layer over an image on Photoshop and added a shadow effect all over the layer.


I didn't see this when I was playing games with my older PC (gefore 9600 GT) on Direct X9. That shadow overuse looks ridiculous and surrealistic. It's like if everyone was "glowing", but black instead of white. Is there anything I can do to disable it??

Thanks!
a b Î Nvidia
December 7, 2012 1:32:54 AM

Can you post a pic so we can see what it is that you mean? Shadows are usually desirable in games to add extra realism.
m
0
l
December 7, 2012 2:14:13 AM

clutchc said:
Can you post a pic so we can see what it is that you mean? Shadows are usually desirable in games to add extra realism.


Sure. Here's a screenshot - I added the circles to highlight what I'm talking about. Notice how the excessive shadow effects make the objects look like they were "pasted" above the picture?



m
0
l
Related resources
December 7, 2012 2:14:33 AM

Wait, why won't the picture showup?
m
0
l
a b Î Nvidia
December 7, 2012 5:31:12 PM

I got the pic to show up. Just hi-lite everything but Try playing around with the 'shadow' options in the game's settings or options.

Have you thoroughly removed the old gfx driver before installing the new one? You might try uninstalling your gfx driver again and then running Driver Sweeper in Safe Mode. Have it remove any AMD, ATI, and Nvidia graphic driver remnants it finds. Re-boot and install the latest driver for your card and O/S.
http://www.guru3d.com/content_page/guru3d_driver_sweepe..." alt="" class="imgLz frmImg " />
m
0
l
December 7, 2012 10:40:39 PM

clutchc said:
Are you running the game at your monitor's "native" resolution?

Yes.

clutchc said:
Try playing around with the 'shadow' options in the game's settings or options.

Tried that already. It is the same in every game.

clutchc said:

Have you thoroughly removed the old gfx driver before installing the new one?

It is a newly built PC on a new SSD drive, new motherboard, etc. There is no old gfx driver.
m
0
l
a b Î Nvidia
December 7, 2012 10:47:14 PM

New system. Well, that would make me wonder about the driver or the card. Since we can rule out the driver, the card itself may be defective. Have you tried...
1) your old card at its DX level in that same PC in the same games
2) run the game at DX 10 (assuming the game(s) are all DX 11 in the first place)
4) tried a friend's card at DX 11 with those games

?
m
0
l
December 7, 2012 11:02:53 PM

clutchc said:
New system. Well, that would make me wonder about the driver or the card. Since we can rule out the driver, the card itself may be defective. Have you tried...
1) your old card at its DX level in that same PC in the same games
2) run the game at DX 10 (assuming the game(s) are all DX 11 in the first place)
4) tried a friend's card at DX 11 with those games

?


1) No but swapping my card from my old PC to my new one and back takes a lot of work that I'm not willing to invest in.
Besides, if it fixes the issue, it doesn't fix my card.
2) If I bought a new PC, it's because I want DX 11.
3) I have the only DX 11 card of all my friends :p  besides, see point 1. All I know is that it doesn't look like that in web screenshots from other people.
m
0
l
a b Î Nvidia
December 7, 2012 11:08:40 PM

I purely meant for testing purposes, not as a solution.
m
0
l
December 8, 2012 12:00:25 AM

clutchc said:
I purely meant for testing purposes, not as a solution.

No problem thanksthough :) 
My PC was supposedly tested by the company who built it (it was custom built by http://www.pcczone.com/ ) and as far as I know, delivered excellent benchmarks and had the latest drivers installed, or that's what my nvidia control panel says. I would really think it's a software issue but it definitely happen in several games.
m
0
l
December 9, 2012 9:01:16 PM

Check your Ambient Occlusion settings in Far Cry 3. SSAO and HBAO seem to actually put shadows in the game while I haven't noticed much of what HDAO does.

I have the same problem as you with my GTX 560, and I'm beginning to think it has something to do with my HBAO setting. I'm going to turn it off and see what happens.


As for your other games, I have no clue.


EDIT: In Far Cry 3, SSAO and HBAO outlines objects with shadows just like in your screenshot, and HDAO got rid of the majority of the outlining, but still showed up on some objects. Maybe check your Video Card control panel and try possibly forcing Ambient Occlusion off specifically for whatever games you're having the problem with.
m
0
l
December 9, 2012 9:47:19 PM

izayaorihara said:
Check your Ambient Occlusion settings in Far Cry 3. SSAO and HBAO seem to actually put shadows in the game while I haven't noticed much of what HDAO does.

I have the same problem as you with my GTX 560, and I'm beginning to think it has something to do with my HBAO setting. I'm going to turn it off and see what happens.


As for your other games, I have no clue.


EDIT: In Far Cry 3, SSAO and HBAO outlines objects with shadows just like in your screenshot, and HDAO got rid of the majority of the outlining, but still showed up on some objects. Maybe check your Video Card control panel and try possibly forcing Ambient Occlusion off specifically for whatever games you're having the problem with.


Thanks for the suggestion. I tried turning off Ambient Occlusion in my Nvidia control panel for all games, I still see it happening in Far Cry 3 though. I haven't tested other games yet but I suspect if there are no changes in Far Cry 3 there are changes nowhere. That said it has always been the most evident in Far Cry 3.
m
0
l
December 9, 2012 9:53:13 PM

gapagos said:
Thanks for the suggestion. I tried turning off Ambient Occlusion in my Nvidia control panel for all games, I still see it happening in Far Cry 3 though. I haven't tested other games yet but I suspect if there are no changes in Far Cry 3 there are changes nowhere. That said it has always been the most evident in Far Cry 3.



Not really sure then. I'm suspecting it has something to do with drivers or software though because I've seen a couple other reports of this happening to people. Either that, or that's just a minor flaw these cards are having.

Only thing I'm seeing on this problem is it has something to do with Ambient Occlusion, so if that didn't fix it, I'm not sure what you could do.
m
0
l
December 9, 2012 10:19:45 PM

izayaorihara said:
Not really sure then. I'm suspecting it has something to do with drivers or software though because I've seen a couple other reports of this happening to people. Either that, or that's just a minor flaw these cards are having.

Only thing I'm seeing on this problem is it has something to do with Ambient Occlusion, so if that didn't fix it, I'm not sure what you could do.


Yeah it doesn't make the game unplayable, but it's slightly distracting. Hopefully Nvidia will come out with a fix.
m
0
l
October 20, 2013 5:36:32 PM

These dark shadows are from games that use SSAO. Far Cry 3 is known to do it the worst. Go into Far Cry 3 in game settings and in video, change SSAO to HDAO and the shadows should be gone. HBAO will show less but it will still be there. HDAO is the most gpu exstensive though so you wont get as good performance as with the other two. Im no expert, this is just from my own self expierence.
m
0
l
a c 80 Î Nvidia
October 20, 2013 9:52:55 PM

HBAO in Farcry 3 does seem to do it a lot, but the reality is, they are attempting to do what happens in reality. You get some shadowing around objects. The problem is that it is sometimes over done. As mentioned, turning off these effects will remove it.
m
0
l
!