Sign in with
Sign up | Sign in
Your question

virtual memory under winxp and win98

Last response: in Memory
Share
Anonymous
a b } Memory
January 17, 2002 7:55:16 AM

Hi all,
Would like to know if with 768 mb of sdram pc133 its could be better to disable virtual memory in both winxp and win98. I know then supposly windows manage his memory like this. He will use virtual memory when ram will be filled. So with 768 mb of ram i schould be able to have enough. Well just want you opinion about that. cya and tnx all
January 17, 2002 9:47:05 AM

instead of disabling it ( a poor choice in some circumstances) add the following parameter to your system ini file in the [386enh] section

ConservativeSwapfileUsage=1

this will force windows to use all of the physical Ram before it swaps out to the HDD virtual memory

lagger

<b><font color=blue>Computers run on smoke, I let the smoke out of mine and it quit working </b> </font color=blue>
January 17, 2002 8:45:03 PM

Don't disable your swapfile. Go with the suggestion above and you might want to assign a fixed minimum on your swapfile of about 250MB.

I run 512MB memory and 500MB of swapfile. Shouldn't ever need it, and I don't worry about it.

<b><font color=blue>~scribble~</font color=blue></b> :wink: <A HREF="http://www.ud.com/home.htm" target="_new">Help cure cancer.</A>
Related resources
January 18, 2002 1:58:32 PM

Yes, use that option and set your virtual memory to a fixed 256 or 512 MB setting.

My case has so many fans that it hovers above the ground :eek:  .
January 18, 2002 2:45:26 PM

fixed at no more than three times memory amount
Anonymous
a b } Memory
January 19, 2002 2:51:04 AM

Why are the disadvantages to disabling virtual memory? I'm planning on building a new computer soon, and I was looking forward to disabling memory once I got 512 MB (originally, I was going to get 1024 MB, but it's not worth it, now). Currently, I have 192 MB of physical memory with virtual memory set to 256 MB (static). That makes about 448 MB of total useable memory on my system (XP Home, btw). Since I've never come close to running out of memory yet, why would I want have virtual memory enabled if my physical memory would exceed my current total memory?
January 19, 2002 8:54:08 AM

Windows needs the presence of a swapfile of some sort (even if its 0) to run trouble free.

Best thing to do is set Windows to manage it for you and in the [386enh] paragragh of the system.ini file, add the line "ConservativeSwapfileUsage=1".

This will ensure all memory gets used before your swapfile. If you ever need the swapfile, Windows will allocate as normal. You probably won't, so forget you have one.

<b><font color=blue>~scribble~</font color=blue></b> :wink: <A HREF="http://www.ud.com/home.htm" target="_new">Help cure cancer.</A>
January 19, 2002 3:17:26 PM

Note 1: The "ConservativeSwapfileUsage=1" line for the System.ini file works in Win98, but not in newer operating systems like Win2K and WinXP. It's not supported in Win95, and there is some testing that indicates little or no performance gain in WinME.

Your best bet, with large amounts of RAM on the mainboard (and if you wish to have a small Swap File) is to set the Swap or Paging File to a very low number, even as low as 2MB, (both minimum and maximum) instead of disabling the file altogether.

Also, in Win9x, with the Swap File virtually eliminated (pardon the pun) and with 768MB of RAM installed, you can set the amount of memory to be accessed as a fixed amount.

Start/Run. Type MSCONFIG, and hit Enter. Under the General tab, click the Advanced button. This will open the Advanced Troubleshooting Settings window. Check the box that limits the memory to a certain amount, and set it to 768MB (or the actual amount of physical RAM in the system.)

Note 2: I <i>really</i> don't recommend doing this unless you have 512MB of RAM or more.

With the ConservativeSwapfileUsage=1 line added to the system.ini file, this will force Windows to always access the physical memory first, and never more than 768MB. You'll find that even under relatively heavy demands, Window will almost never attempt to access the Swap File with these settings in place.

With that much RAM, you'll also need to add this line to the [vcache] section of the system.ini file:

MaxFileCache=262144

Adding this line will avoid any potential out-of-memory errors and memory address conflicts.

In operating systems such as Win2K or WinXP, the memory management is far better, and the Virtual Memory will only be accessed when actually needed, which is the exact reverse of Win9x. I have a 768MB Paging File in Win2K, but it has never been accessed to my knowledge. I just leave it, one-because I've got ample hard drive space, and two-because Win2K just doesn't need any user help for memory management. It does quite nicely without any interference. The same applies to WinXP.

Note 3: There are certain programs, like some games, that simply won't install without detecting a Swap File. Some even require a Swap File of a certain size.

Note 4: There's almost no performance advantage to installing 768MB of RAM with a Win9x operating system.

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
January 19, 2002 4:40:09 PM

Quote:
Note 3: There are certain programs, like some games, that simply won't install without detecting a Swap File. Some even require a Swap File of a certain size.

Someone told me that Adobe Products use the swapfile before the memory. I find this hard to believe. I've used Acrobat and not seen my swapfile being utilised. Any comments?

<b><font color=blue>~scribble~</font color=blue></b> :wink: <A HREF="http://www.ud.com/home.htm" target="_new">Help cure cancer.</A>
January 19, 2002 6:23:35 PM

I find it hard to believe, too. It's certainly not happening on my system when I run Photoshop, even when I use many filters in one session.

The same thing applies to Acrobat, Illustrator, Premiere, or ImageReady.

I once set up my system with Win98SE, adjusted the system.ini file, and manually restricted the memory to 512MB. I fired up Photoshop and loaded a 125KB random image. I had to apply 47 radial blur filters to the image, one after the other, before I ran out of memory. (The file was pretty darn big when I was finished ... somewhere around 150MB!) At that point, if I had enabled the Swap File ... that's when the program would have gone to the disk.

I was running with a 2MB Swap File, at the time, just to see when the system would finally send me an out-of-memory message.

I really don't know how far I'd have to go with my current configuration before the paging file would be accessed. I'll have to test it sometime, just for the heck of it, and see for myself. With a gigabyte of memory on the board, I expect that it would take a while.

That's my comment!

Toey

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
January 22, 2002 11:17:59 AM

I thought Adobe products needed something called a scratch disk ? I'd assumed this was the paging file ?
January 22, 2002 3:53:12 PM

Yes ... and no. Take a look at this <A HREF="http://www.adobe.com/support/techdocs/16592.htm" target="_new">page</A>.

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
!