Sign in with
Sign up | Sign in
Your question

Connecting an XP Mode VBox to a Win7 Workgroup

Last response: in Networking
Share
January 13, 2012 5:10:05 AM

I’d like to connect a Windows XP Professional x86 virtual box via XP mode on Windows 7 Enterprise x64 to a home network. I’m trying to use the workgroup option.

Just so I don't come off as lazy, I’ve been at this for days and Google’d half the net. Not trying to waste anyone’s time, I just need help at this point.

The computer is:
i7-3930k on a P9X79 Deluxe motherboard, which has two LAN ports and a wireless connection. It has 32GB of 1866MHz RAM, and running on a pair of (not-RAID’d) Crucial m4 SSD’s. It’s running Windows 7 Enterprise x64. All drivers, firmware, and BIOS are fully up-to-date. (Odd note: The P9X79 Deluxe the 0906 BIOS released about a week or so ago, which I’m using. It’s no longer up for download on the official page. Not sure what’s up with that.)

The network is on a Linksys WRT-610N Revision 2 (which is pretty much the older version of the Linksys E3000). The router also has the most up-to-date firmware. The ethernet wires are Cat 7's. The desktop in question is connected to the router via both LAN ports, though Win7 has only been using one. I connected the second recently in hopes that the VBox would be able to use it when I couldn’t get it to work any other way. No luck yet.

I also have a few laptops using the wireless. The desktop in question and the laptops see each other on the “WORKGROUP” workgroup just fine.

What DOES work:
-Win7 computers, including the desktop in question, see each other and can use the internet.
-XPmode can use the internet.

What does NOT work:
-Win7 computers, including the desktop, can’t see the desktop's XPmode.
-When I select “View workgroup computers” in “My Network Places” in XPmode, I get the following error message:
Title: “My Network Places”
Error line 1: “Workgroup is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.”
Error line 2: [empty]
Error line 3: “The list of servers for this workgroup is not currently available.”
Error buttons: “OK”
Error icon: [white X in a red circle]

Only registry fix that I’ve tried: http://support.microsoft.com/kb/913628

From the “Windows XP Mode – Windows Virtual PC Settings” -> “Networking” tab, I’ve tried setting the adapter to the “Shared Networking (NAT)” adapter and both of the actual LAN adapters, one at a time, with lots of restarting the virtual box. Always the same problem.

Does anyone know what else I might try to get things working?
January 13, 2012 5:49:06 AM

Update: Progress!

I told the desktop's Win7 to connect via wireless (which seems stupid since it's got 2 LAN's plugged in, but I'm desperate). I then gave the XP mode control over both the "Shared Networking (NAT)" adapter AND the primary LAN adapter. Now XP mode sees itself on the workgroup instead of the error message.

Problems:
1. Now my desktop apparently has to use wireless when it already has two LANs plugged in...
2. All Win7 instances still don't see the XP mode instance.
3. XP mode instance doesn't see any Win7 instance.
m
0
l
January 19, 2012 3:22:11 PM

The Shared Networking (NAT) adapter is the problem. Remove that adapter, and just use one of your other adapters as the XP Mode adapter in bridged mode.

The Shared Networking (NAT) adapter works through Network Address Translation (NAT) which uses the host to route traffic to the VM. This does not allow the VM to be on the network the same as a normal computer. Bridged mode will allow both the host and virtual environment to appear as physical machines connected to the network.

The difference between the different network settings is described in the help file pretty well. When you have the VM settings open and you click on the Networking option (same place you change the network card modes), at the bottom of the right pane, click the link that says “More about networking and virtual machines”.

I tested this myself. My test setup:

1 laptop (Windows 7 Ultimate) on a domain. Windows XP Mode on this laptop.

2 other pc’s on the home network (both Windows 7, both on WORKGROUP)

Before changing the adapter settings, I could not see any computers from within XP Mode and was unable to see the XP VM from any other computer.

I shut down the VM and changed the adapter from Shared Networking (NAT), to the only other adapter I am using (wireless adapter). Re-started the VM.

VM is now visible from any of the other computers on my home network, and the VM can now see all of the computers on the home network.
m
0
l
December 17, 2012 12:20:30 AM

Thanks for sharing that, WinOutreach4. It was very helpful in getting my VirtualXP box "on the air"!

Now I would like to share a little bit more in return. I'm a rather lazy but impatient person. Rather than shut down the VM, make the change (Tools > Settings > Networking on the VM's toolbar) and then wait for the VM to restart I simply made the change with the VM still running.

Then, in the "My Network Places > Network Connections" I right-clicked the network connection and clicked "Repair". That worked a treat!! I was immediately able to see the other computers and their shares from the XP VM.

That last (repair the connection) might not even have been necessary but I thought it might be prudent since the repair function shuts down and restarts everything related to the adapter for the selected connection.

Cheers!
m
0
l
!