Sign in with
Sign up | Sign in
Your question

System shuts down while in sleep mode

Last response: in Systems
Share
January 22, 2013 9:33:24 PM

Hi guys,
I built a Core i7 3770k, AsRock OC Formula, 650 watt PSU running Windows 8 64-bit computer last month. It has had some minor problems, as with any new build, but I fixed them with some simple adjustments.

Now (within the last week or so), it seems like at random, the computer will shut off while it is in sleep mode. The power button on the case stops lighting up, and when you turn the computer back on, it will whir up for about 2 seconds, shut completely off for 2 seconds, turn back on, and hang at the AsRock BIOS screen (press F2 to.....). Post on the MB stops at "IDE device detected". No HDD activity, nothing; although everything seems to be powered on fine. At this point, I press the power button once and the machine shuts off instantly. I press it again, and the machine boots up as normal, no hangs or errors whatsoever.

This seems to happen within a random time period (sometimes 3 seconds, sometimes 2 minutes) every time I put the computer into sleep mode, and regardless of whether an iphone or other usb device is plugged in or charging. If I shut down all the way, I have no problems at all. But I want to use sleep mode!

If anyone has any suggestions or solutions, I would like to hear them.

Thanks
a c 136 B Homebuilt system
January 22, 2013 11:20:16 PM

Firstly enter BIOS and set your hard drive to run in AHCI mode . Also enable SMART monitoring . If you have an SSD disable hibernate too

Then head for control panel and power options

How are your power options configured?
m
0
l
January 23, 2013 4:48:06 AM

Update: from the time of my first post to now, my system was successfully in sleep mode. I had no USB devices plugged into it. It seems that when I charge my iphone or ipad during sleep mode, the problem occurs more frequently. The MB is designed to be able to handle charging during sleep.

All drives are in ACHI mode with SMART enabled. OS is on bootable kingston ssd. Did not see settings for disabling hibernation on it.

Power options:
Put computer to sleep: Never
USB selective suspend setting: enabled
power button action: sleep
sleep button : sleep
system cooling policy: active
Everything else set for max. performance.

Should mention that I just installed a blu-ray burner. Also has an IDE DVDRW burner with an IDE to SATA adapter. They all work without a hitch. No video cards. Using integrated graphics.

Also, only one stick of ddr3 RAM 8GB 400mhz (not the most familiar with RAM, but you get the gist I hope?)

m
0
l
Related resources
January 23, 2013 4:50:44 AM

I cant remember if I had the problem before I installed the bluray, but would there be any way it would cause that much of a problem as to ruin sleep mode? It works perfectly; I have watched movies and burned with it a few times without any problem.
m
0
l
January 24, 2013 8:20:47 AM

If anyone is interested, I have changed all of my sleep button settings to hibernate just now. I will see if the computer works as it should. This is not a solution, as waking from hibernate is much slower, and I can't charge my phone that way, but all I can do for now. I have tried just about everything.
m
0
l
a c 136 B Homebuilt system
January 24, 2013 8:59:25 AM

try resting things so the power button is an on/off switch

also let the power saving system sent the pc sleep after a reasonable time of not being used

I think you should try that and see if it makes a difference

And it will make manually putting it to sleep a little tedious with mouse but that would be better than what you have now
m
0
l
January 24, 2013 12:51:48 PM

Sorry, no difference at all with any of those settings. Its so strange. Everything else on the computer works without a hitch but sleep mode.
m
0
l
January 24, 2013 12:58:51 PM

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Date: 1/24/2013 6:34:21 AM
Event ID: 41
Task Category: (63)
Level: Critical
Keywords: (2)
User: SYSTEM
Computer: LeBeast
Description:
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
<EventID>41</EventID>
<Version>3</Version>
<Level>1</Level>
<Task>63</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000002</Keywords>
<TimeCreated SystemTime="2013-01-24T14:34:21.822589700Z" />
<EventRecordID>7479</EventRecordID>
<Correlation />
<Execution ProcessID="4" ThreadID="8" />
<Channel>System</Channel>
<Computer>LeBeast</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data Name="BugcheckCode">0</Data>
<Data Name="BugcheckParameter1">0x0</Data>
<Data Name="BugcheckParameter2">0x0</Data>
<Data Name="BugcheckParameter3">0x0</Data>
<Data Name="BugcheckParameter4">0x0</Data>
<Data Name="SleepInProgress">4</Data>
<Data Name="PowerButtonTimestamp">0</Data>
<Data Name="BootAppStatus">0</Data>
</EventData>
</Event>
m
0
l
January 26, 2013 12:44:40 PM

Sooooo. I found an annoying little workaround that tells me this is not a hardware problem, but some kind of secret, nearly impossible to find software bug.

Spent a whole day on the phone with Microsoft. The first guy I talked to changed nearly every setting on the computer around; the problem remained. The second guy took the easy way out and merely reinstalled Windows 8 over my old installation, making me have to reinstall all of my programs as well. This didn't work either. Stay away from Microsoft support if you know computers.

My workaround:
After googling for "sleep mode software" or something like that (looking for a different way to sleep, other than the S1 or S3 states - couldn't find anything),I stumbled upon a program called "Passmark Sleeper". It is a sleep mode testing program. And although my BIOS won't allow me to switch between standby states, this program allows me to "test" S1, S2, S3, or S4 states. I simply choose the S3 option and the "sleep forever" modifier (this program normally only tests each mode for 30 seconds), and voila! Sleep mode works again! I had my computer asleep for nearly 8 hours, and it woke flawlessly! Too bad I have to use a third party app to get it to work.....

Anyone have any idea what kind of bug might be causing this now that we know its not some hardware problem? I still want to get to the bottom of this mess.
m
0
l
February 2, 2013 6:13:17 AM

Passmark Sleeper stopped doing the trick. I reinstalled Windows 8, no fix. Updated drivers, no fix. My problem may be my power surge protector. I have plugged the computer directly into the wall and have not had a problem yet, although I have not had the computer in sleep mode for long periods. I will keep you updated.
m
0
l
February 2, 2014 3:11:16 PM

nearyetsofaraway said:
Passmark Sleeper stopped doing the trick. I reinstalled Windows 8, no fix. Updated drivers, no fix. My problem may be my power surge protector. I have plugged the computer directly into the wall and have not had a problem yet, although I have not had the computer in sleep mode for long periods. I will keep you updated.


I don't know if i am having the same issue as you or not. Occasionally when my computer goes to "sleep" even though i have sleep set to never and monitor to turn off after 15 mins. If i move my mouse, press a key on my keyboard, or hit the power button the monitor will not come back on but the lights on the front of my case that indicate power etc are all still on. Is this the same as what you're having issues with?
m
0
l
!