Sign in with
Sign up | Sign in
Your question

Problem with monitor native resolution

Last response: in Graphics & Displays
Share
December 8, 2012 4:04:12 PM

Ok, so i have an LG W2243S-PF 22' full hd monitor. I have a 64-bit W7 installed with 12.10 catalyst (sapphire hd5850) and with the w2243 driver from LG's website. It works fine on 1280x720, but when I try and set it to 1920x1080 (which is the native res), it gets weird and flickery. Here are two pictures:

http://kepfeltoltes.hu/121208/IMG_20121208_185130_www.kepfeltoltes.hu_.jpg
http://kepfeltoltes.hu/121208/IMG_20121208_185135_www.kepfeltoltes.hu_.jpg

Have you got any ideas what this might be? Also, I couldn't find a better place to post this... Is there such place? Thanks in advance!
December 8, 2012 4:24:48 PM

Not sure, but you could try fully uninstalling the video card drivers and rebooting.
Then go to AMD's website and installing their latest drivers.
December 8, 2012 4:26:00 PM

Also, if the monitor came with any monitor driver, you should also install that too.
Related resources
December 8, 2012 4:35:03 PM

The w7 is a fresh install, the monitor driver and the catalyst is installed freshly.

EDIT: I use a DVI-VGA adapter, because the monitor only has a VGA input. Does that matter?
December 8, 2012 5:19:03 PM

Uninstalling the monitor driver and disabling the edid recognition and setting maximum possible resolution in amd vision engine control center fixed the problem!
December 8, 2012 5:26:11 PM

Good to hear.
!