Sign in with
Sign up | Sign in
Your question

Wireless not connecting to internet

Last response: in Wireless Networking
Share
January 17, 2012 12:30:08 PM

Hello,

I am trying to help my neighbour get his wireless router working. He has a D-Link DIR-615 Wireless N 300 Router. I have gotten the router working by manually putting in his PPPoE settings. Now with a wired XP SP3 computer connected via Ethernet, it can access the internet. We then configured his router for WPA2 with AES encryption. We were able to connect up his phone which can handle a WiFi connection. He was able to surf the web using the WPA2 passphrase. So far, so good. The last bit was the upstairs computer which has a PCI D-Link wireless N card in it. That computer runs XP SP2 and we have not been able to get it to connect to the internet.

We have tried both Windows networking, and the D-Link Wireless management software. We were unable to get WPA2 working, so we tried WPA, WEP, and finally no security. In each case, we can get the computer to connect to the router by putting in the passphrase (except when no security), and the status changes to Connected. But then browsers are not able to open any internet site.

I have checked the ipconfig settings, they seem to be correct. DHCP is providing the computer with a valid local IP (192.168.0.102), and the gateway is correctly listing the D-Link router. Subnet mask is 255.255.255.0. The downstairs Ethernet connected computer has an IP of 192.168.0.100, so they are on the same subnet. We have tried turning "Windows Wireless Zero Configuration" service off, and also tried with it on. We have switched between using the D-Link client and allowing Windows to manage wireless settings. It finds the wireless network, and connects with the passphrase with a good strong signal, but internet persists in not working.

I do not have MAC Filtering turned on. I have turned off the Windows Firewall on the wireless computer. What else am I missing?
a b F Wireless
January 17, 2012 12:52:31 PM


Hello and welcome to Tom's Hardware Forums.

Have a look in Control Panel>Internet Options>Connection tab>LAN button and tick "Automatically detect settings" then untick both of the Proxy options. Click Apply and OK your way out then start IE and try again. If that fails, you could get SP3 in there and see if that helps.

January 24, 2012 2:34:43 PM

Thanks, downloaded and installed SP3 onto a thumb drive. Copied it over, installed it, and same problem. The Proxy options as far as I know affect IE only. FF has it's own proxy settings, all of which are blank.
Related resources
a b F Wireless
January 24, 2012 5:09:51 PM



IE's Tools>Internet Options menu is only a shortcut to the section of the sme name in Control Panel and I believe those settings overarch anything Firefox has to offer, but I could be wrong. It's certainly worth a shot.

I would also let DHCP handle the automatic allocation of IP addresses

January 27, 2012 12:48:02 AM

Yeah, tried that. Latest attempt was to use the D-Link Wi-Fi Protected Setup with the big magic button. It connected the two computers via WPA2, and said successful. But still no internet from the wireless client. The ethernet connected computer is fine, it goes through the d-link router to the internet without any issues. But wireless can see the router and connect to it without problems, acquires an IP from the DHCP server on the router, and everything looks great. Just FF comes back with error message when trying to get to google.

a b F Wireless
January 27, 2012 6:03:59 AM



It's very odd. Have you tried another site or just Google? The only other thing you culd try is temporarily suspending security at all - just for long enough to see if the errant wireless adapter has a problem with WPA2. Some older adapters can't get through it.


February 3, 2012 11:43:46 AM

Yes, I have tried that as well. I can't explain it, I have gotten wireless working at many people's houses, but I can't get it working there.

Here are some of the things we have tried :
- Set security to off. The computer connects to the router without a problem, acquires an IP, and is listed as CONNECTED! Internet won't work with IE or FF.
- Used WPS (wireless protected setup) and allowed both D-Link devices to set themselves up. Again, CONNECTED, this time with WPA2, but no internet.
- Installed SP3.
- Ran Windows repair.
- tried "netsh winsock reset"
- tried "flushdns"
- Tried setting manual IP (with same subnet), subnet, gateway, and DNS.
- Reset to auto-config to acquire IP address. Again, acquired an address, connected, no internet.

- Got frustrated, returned PCI D-Link NIC, bought D-Link USB NIC instead.
- Same story. Connects quickly to router, all OK, no internet.

Here is the weird part. After trying for hours, we left it for the night. When my neighbour looked at the computer the next morning, it had connected to Windows Update and downloaded 136 updates! It was working away all night, happily downloading them. So he told the computer to install them all and went to work. When he came back, they were all installed (no errors). And... no internet.
- Same thing happened that night. It found a few more updates, downloaded them.
- Reset to default IE settings. No dice.
- Reset FF settings. No dice.

- I can connect to a network share on the wired computer, no problem. Can ping the router, and the other computer on the LAN.


Any other ideas?
a b F Wireless
February 3, 2012 5:28:56 PM



It's going to sound silly to set the browsers as exceptions in Windows Firewall but it's my only shot! :D 

February 9, 2012 5:07:43 PM

We have turned the Firewall completely off. Same deal. I am stumped. Am at the point of format/reinstall.

Any other ideas?
a b F Wireless
February 10, 2012 5:34:43 AM



I suppose it isn't possible the browsers are set to Work Offline? Can you get another browser - preferably Firefox - in there using a flash drive? If so, don't allow it to import any settings from IE - let it have a clean start.

March 5, 2012 12:53:11 PM

Fixed it. Finally. It was Norton Firewall. In our attempts to get this working, we would disable Norton. We would get the popup saying it was disabled, we were at risk, blah blah blah. But it still wouldn't connect. The key was the fact that Windows updates were getting through at night. That meant it was properly connecting to the router, but something was preventing it from connecting to internet sites when using a browser. At that point, we stopped trying to reconfigure different wireless schemes, and just went back to pushing the big PUSH ME AND I WILL CONFIGURE MYSELF button. The router set itself up with WPA2 and AES by default. We could access shares on either computer, and had a strong signal.

So now that we were pretty sure the wireless was set up correctly, we concentrated on non-wireless stuff. We tried different DNS settings first, trying to connect to sites via an IP instead. Then we tried different browsers in case IE and FF had some weird security setting, or were stuck in offline mode. Then we just started deleting anything which might cause a problem. When we got to the TURNED OFF Norton Firewall, we uninstalled it. And presto, everything worked.

Then we just went with Windows Firewall, and that was that. It all works now.
a b F Wireless
March 5, 2012 2:00:53 PM



Well done - proof if proof were needed that Norton products are more trouble than they're worth.


!