Belkin N600 DB wireless Router is getting no internet connection from Modem

Just purchased a Belkin N600 DB N+ Wireless Router because the wireless on my Actiontec PK5000 really isn't so great. When I hook up the router to my modem and after running the install CD I couldn't get connected to the internet. So I looked at my modem and noticed the light where I had plugged in my router VIA ethernet wasn't lit up like the rest of my ethernet ports even after switching them around.

Is this a faulty router or is there an issue between my modem type and router. Also I read somewhere the Belkin router is supposed to have a blue light mine has a faint pinkish light.
6 answers Last reply
More about belkin n600 wireless router internet connection modem
  1. Are you plugging the Ethernet cable from the modem into the yellow port located on the back of the belkin router?

    Is the actiontec a router/modem? Basically are you still using that device as your modem? If so you have to turn off DHCP on the belkin. That way it will let the Actiontec handle the IP addresses and won't conflict with each other.
  2. Yea I have the ethernet cable plugged into the yellow jack. I have the Actiontec as a modem but it has a wireless feature. My issue is I can't connect to the Belkins settings wireless or by ethernet.
  3. Xuany said:
    Yea I have the ethernet cable plugged into the yellow jack. I have the Actiontec as a modem but it has a wireless feature. My issue is I can't connect to the Belkins settings wireless or by ethernet.



    So if you hard wire a computer to the Belkin router you can not log into it?
  4. Yea exactly at this point I'm thinking of returning it unless there is something else I haven't done to where I couldn't connect to it by hard wire.
  5. Xuany said:
    Yea exactly at this point I'm thinking of returning it unless there is something else I haven't done to where I couldn't connect to it by hard wire.

    Hi ,
    Try manually assigning the following to your computer
    192.168.2.2 as ip address
    192.168.2.1 as default gateway

    Then try accessing the router by default gateway
    You'll be able to access your router.

    Then make the necessary changes. In your case try cloning your system mac address to your router. Its harmless and worth try.

    Let me know at kulkarni.roy@gmail.com
    Roy
  6. Sorry, still thought it was 2012
Ask a new question

Read More

Configuration Wireless Router Routers Modem Belkin Wireless Networking