Sign in with
Sign up | Sign in
Your question

Need help with old graphic card (Radeon 9800 Pro)

Last response: in Graphics & Displays
Share
December 10, 2012 11:12:02 AM

Long story short, I tested a friends graphics card in my homebuilt computer to see if it worked. I took my Ati Radeon 9800 Pro out, and put in this other card, and then replaced the other card back with my Ati Radeon 9800 Pro. Since then, I cannot get the drivers to work again for my 9800.

I have Windows 7. I am positive that I did a fresh install of windows 7, not an upgrade. I cant remember if I installed specific drivers for my graphics card at that time, or if windows did it. All I know is that the card was running good, with two monitors running together. Everything stopped working after I tried my friends card out.

Ive downloaded so many Ati Catalysts, 10.2, 9.3, 9.1, 8.7, 8.1, and also different versions (XP and Vista) and none of them will work. Sometimes it will just say "The current driver is up to date" and its showing the standard VGA graphics adapter. Sometimes it will say "Radeon 9800 PRO installed, reboot now" then when I reboot, it will give me this error
"Windows cannot initialize the device driver for this hardware. (Code 37)" when I check device manager.

Basically what I was doing was boot into safe mode, use DriveSweeper to delete all ATI files, then reboot and install different catalyst, then go through device manager to "update driver". Then I would get the error above.

So now, In my device manager I have this (both with the exclamation point on them):

RADEON 9800 Pro
RADEON 9800 Pro - Secondary

and in control panel display I am only showing one monitor (not my 2nd monitor), and it just says "default monitor on".

From what I found out, the 9800 Pro is such an old card that windows 7 has no drivers for it...but like I said it was working perfect before, until I tried my friends card out.

My hardware:
Asus Ic7-g
Radeon 9800 Pro AGP
4GB memory
P4, 3Ghz

Thanks a bunch.
December 10, 2012 12:51:01 PM

Thank you for the reply.

I uninstalled the previous driver, installed the 32 bit one, and as it said detecting graphics hardware, it gave me the error "Failed to load detection driver".

I went to device manager and to display adapters, and clicked update driver, and went to the 32 bit ATI folder. It installed, and says "Radeon 9800" in device manager. I rebooted, and in device manager it has exclamation points on the 9800 and says "Windows cannot initialize the device driver for this hardware. (Code 37)".
m
0
l
Related resources
a b U Graphics card
December 10, 2012 12:57:20 PM

Hummmmm..... Does the card have any markings on it that say which model and manufacturer the card is? We may be barking up the wrong tree. You can still see stuff on your screen, right? It's probably using the standard Windows VGA drivers for that.
m
0
l
December 10, 2012 1:05:36 PM

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

That is the exact card I have in right now, I ordered it way back when from newegg.

Yeah I can still see everything on my screen but my max resolution is 1280x1024, and its not detecting my other monitor. You are correct its using the standard VGA drivers right now.
m
0
l
a b U Graphics card
December 10, 2012 1:48:38 PM

Well, Sapphire has no Windows 7 drivers for that card. Do you have the original CD that came with the card? Have you tried taking it out of the slot and re-seating it? Sometimes that will help a connection problem. If that doesn't work I have no other suggestions but to re-install windows fresh or replace it.

Here are a few ideas for replacement:
http://www.newegg.com/Product/ProductList.aspx?Submit=E...
m
0
l
!