Odd issue with 4870x2

Years ago I purchased an HD 4870x2. The thing stopped working just after the warranty expired, so I purchased a 560 ti which has been running fine. Last week I decided to upgrade my mobo/ram/cpu and just for the sake of curiosity, I decided to pop in that old 4870 and it worked! I have all my old parts in another case ( different power supply, but it's 750w so it should be fine ) and the 4870 won't work in that machine. The same machine that ran it for the first year and was running a 560 ti until a week ago just won't run that card and I'd like to figure out why.

tl;dr: 4870x2 works in one machine, but not in the other. How can I figure out why?

Mobo: P5Q pro turbo
PSU: Corsair TX 750
VGA: HD 4870 x2 ( to clarify, that is the name of the card. I am not using 2 of them in crossfire)


edit: I just remembered that I noticed 3 red lights flash on then back off when I boot on the non-working machine. I didn't notice one way or the other on the working machine.

edit2: Looks like the 3 red lights is a power error code... I wonder if my PCI-e power is on the same rail. Would it help if I used one of the molex( the one with the 4 hole female ends?) converter?
7 answers Last reply
More about issue 4870x2
  1. What's the power supplies in both new and old system?
  2. Old PS - Corsair TX 750

    Newer PS is a TX 850
  3. It is very basic, but have you checked if the mobo is CF ready?
  4. jemm said:
    It is very basic, but have you checked if the mobo is CF ready?


    It is a single card. 4870 x2
  5. Seems to me that your old could have had BIOS compatibility issues with it. Try updating your BIOS and it might just work.
  6. jaideep1337 said:
    Seems to me that your old could have had BIOS compatibility issues with it. Try updating your BIOS and it might just work.



    Interesting... there is actually a BIOS update from just 2 months ago. I haven't been able to find any documentation saying what the update is for, but it's worth a try.
  7. I took the GTX 260 out of my wifes computer and installed it in the machine in question. I was able to update the bios as suggested, but when I put the 4870x2 in there, again no video output.
Ask a new question

Read More

Radeon Graphics Product