Sign-in / Sign-up
Your question
Solved

Is My Brand New XFX Radeon 7970 Faulty?

Tags:
  • Graphics Cards
  • Radeon
  • Graphics
Last response: in Graphics Cards
December 11, 2012 10:35:50 PM

" alt="" class="imgLz frmImg " />" alt="" class="imgLz frmImg " />on the 9th of December, 2012 3 days ago i purchased a XFX Radeon 7970 xXx Double Dissipation Black Edition from centrecom for $409 dollars. The first day i used it, it was fine but then the second day i was playing Gmod then randomly i got artifacting, but just glitchy textures my whole screen went all Distorted and stretched, my second screen was still working fine but my first one was all artifaced or however you call it, then the next day i got loads of artifacting again, 2 times while watching youtube and two more times playing assasins creed III but when i was playing it was just all pixleated and artifacting but not distorted and stretched still able to move my character fine etc, once that happened i closed it immediately, i then played left 4 dead 2 then a few seconds later i opened a youtube video on my second screen then boom stretched and distorted again! By the way i have not overclocked it more than the factory set one, haven't modified anything whatsoever just pretty much using it straight from the box and my temps are not going over 65degrees so im 100% sure its not due to overheating I',m thinking about returning it to Centrecom today (later since its 1am) but i want to see some reply's from you guys first! Greatly appreciated if you did :D 
BTW my specs are
AMD Phenom II x4 970BE stock 3.5GHz
AMD/ATI Radeon 7970 as of current ^ used to be A 6970(worked fine for 1 ½ years no artifacting/problems only 85+degrees gaming also still works)
750w PSU
8gb Ram DDR3 Corsair
WD caviar black 1tb /w OS windows 7 prof
WD caviar green /storage

Oh, and if i do in fact return it and they can possibly give me store credit i might just go buy a GHz edition one http://www.centrecom.com.au/catalog/r797to-gigabyte-797...

More about : brand xfx radeon 7970 faulty

December 11, 2012 10:44:57 PM

Your GPU may be faulty, but I don't think that's the problem. It's most likely either a driver issue or something software related. Maybe your settings are a bit off or whatever. Although, I could be completely off.
m
0
l
December 11, 2012 10:51:01 PM

hi, thanks for replying but i don't think its the drivers i've reinstalled the latest ones and did not work (beta 12.11) then used driver sweeper and installed the last stable one still happens. Also it happens on games randomly and also on youtube vids or any other videos online
m
0
l
Related resources

Best solution

a b U Graphics card
December 11, 2012 11:01:23 PM

Sounds like a bad card to me. RMA and get a new one. Be sure to uninstall the previous drivers before you install the new card. The current drivers do not work if the new card is a different series from the old one (i.e. 6970 to 7970) even if the file used to install form is exactly the same.
Share
December 11, 2012 11:08:35 PM

Quote:
Sounds like a bad card to me. RMA and get a new one. Be sure to uninstall the previous drivers before you install the new card. The current drivers do not work if the new card is a different series from the old one (i.e. 6970 to 7970) even if the file used to install form is exactly the same.


Yeah thanks for the reply, i'm probably going to RMA it later today, but just before i ran furmark but when i ran it for about 15 minutes i did not get any signs of artifacts nor did my GPU exceed 72degrees at 55% fan speeds. No artifacts, No overheat, No Overclock, Nothing. No tweaks! now im starting to wonder whats going on :??:  (BTW when gaming say BF3 Ultra my GPU doesnt go over 65degrees also)
m
0
l
December 12, 2012 7:34:28 AM

Best answer selected by firaaero.
m
0
l
December 12, 2012 7:35:33 AM

JKatwyopc said:
Sounds like a bad card to me. RMA and get a new one. Be sure to uninstall the previous drivers before you install the new card. The current drivers do not work if the new card is a different series from the old one (i.e. 6970 to 7970) even if the file used to install form is exactly the same.


Thanks! I have returned it to centrecom and they immediately replaced my card with a new one as soon as i showed them the pictures! Thanks to all that have replied. Hope my card now works well and lives a nice long gaming life ! :wahoo: 
m
0
l
a b U Graphics card
December 12, 2012 7:44:36 AM

So many issues with XFX cards all the time on these forums, and always with the 7970. Something must be majorly wrong with their 7970's.
m
0
l