Sign in with
Sign up | Sign in
Your question
Closed

Having troubles

Last response: in Graphics & Displays
Share
December 12, 2012 4:38:48 PM

Okay, Right now I use a ati 5450, which is why I need an upgrade.
I use a 500w ATX powersupply.

I bought a brand new 4850 ati POWERCOLOR from Ebuyer, and I tried putting it in BUT i found out I needed a 4pin to PCI E adapater, so I went ahead and picked that up.
I set it all up today, and it all fit in perfectly however when I start the pc up there's lines all over the computer,
I installed the driver however it doesn't even go onto the PC, I can't login because the screen just fails, the alternative is to use safe mode which allows me to see my screen, even with drivers installed I get the problem, even in the BIOS theres lines all over the screen
So i went back to the 5450 and Its absolutely fine.. :( , Im thinking /confused about what to do now.. because the 4850 is openened and I really don't want to waste the £65. (16 and had to make my own money)
Any help will be greatly appreciated

More about : troubles

December 13, 2012 4:06:35 PM

Rasil23 said:
Okay, Right now I use a ati 5450, which is why I need an upgrade.
I use a 500w ATX powersupply.

I bought a brand new 4850 ati POWERCOLOR from Ebuyer, and I tried putting it in BUT i found out I needed a 4pin to PCI E adapater, so I went ahead and picked that up.
I set it all up today, and it all fit in perfectly however when I start the pc up there's lines all over the computer,
I installed the driver however it doesn't even go onto the PC, I can't login because the screen just fails, the alternative is to use safe mode which allows me to see my screen, even with drivers installed I get the problem, even in the BIOS theres lines all over the screen
So i went back to the 5450 and Its absolutely fine.. :( , Im thinking /confused about what to do now.. because the 4850 is openened and I really don't want to waste the £65. (16 and had to make my own money)
Any help will be greatly appreciated



Um, still need help lol
a c 290 U Graphics card
December 13, 2012 4:10:17 PM

Looks like the HD 4850 is damaged. Just return it to the shop and make them give you another one/fix it. It comes with warranty, after all.
December 13, 2012 4:17:24 PM

Sunius said:
Looks like the HD 4850 is damaged. Just return it to the shop and make them give you another one/fix it. It comes with warranty, after all.


Okay if this is the only solution, Ill do this, but I'm open to try any tech fix solutions lol
!