Sign in with
Sign up | Sign in
Your question
Closed

IP Conflict when moving between Wifi Router and Wifi Repeater

Last response: in Wireless Networking
Share
January 20, 2012 8:25:49 PM

Hello,

I have a Wifi ADSL Router (2Wire 2701HGV-W) and a Wifi AP set to Repeater mode (TPLink TL-WA730RE). I work for a community organisation and have been handling their networking problems. There are about 30 laptops in the organisation.

The Router IP is 192.168.1.1 and the Repeater IP is 192.168.1.254. The Router has DHCP enabled (192.168.1.2-192.168.1.253). The Repeater has DHCP disabled.

My problem occurs when I move from the area around the Router (which assigns the IP address to my laptop) to the area around the Repeater.

The laptop connects to the repeater just fine, and sometimes it works fine. However, sometimes I get an IP conflict even though the connection status/details shows that the IP address remains the same. It is as though the Router is holding on to the IP address from when the laptop was connected - thereby causing a conflict when the same computer tries to use the same IP while connected to the router.

I have tried turning on the Repeater's DHCP server with a range of 192.168.2.xxx but it says it is a bad allocation pool and will not work. I have also tried the range of 192.168.1.220-192.168.1.240 (outside of the range of the Router DHCP server) but this does not work either because there is still a conflict.

I have tried assigning static IP addresses from the Router - and this normally works just fine. However, sometimes the router forgets the static address I have assigned and reverts to dynamic IP assignment. This results in the problem reappearing.

I have also tried assigning each computer a static IP on the adapter settings (Windows 7) - however, when I want to connect to other Wifi networks the settings I use mean that I have to readjust the adapater/TCPIP settings every time I use another wifi network.

So I have 3 potential fixes:
1) Adjusting the Repeater with DHCP settings that assign a different IP if the computer connects to it.
2) Finding a way to make sure the Router does not forget the static IPs that I assign in the web browser control panel.
3) Finding a way to make Windows 7 only use the adapter/TCPIP settings for this particular network SSID and return to dynamic assignment when connecting to other networks.

I was wondering if anyone could help me with the best fix. The most simple option would be to make sure the Router stops returning to dynamically assigned IPs when I have set a static IP to a particular computer - however, I am open to ideas of how to fix this problem. There must be a way! :) 

Hope you can help me.

Regards,

Robbo24
January 20, 2012 9:30:25 PM

I assume that your AP has the same SSID and it uses a different pair of radio channels already. I would not use its DHCP server, just stick with the main router assigning addresses.

In the router DHCP server you should be able to reserve dynamically assigned addresses for specific devices by MAC address if that has been an issue. The other choice is to shrink the DHCP assignable range and use static addresses in the network range but outside the dynamic assignment range.

You can't use a different network on the repeater, i.e. .2.x with a .1.x router unless the networks are bridged. That would not be helpful in the circumstances that you describe anyway.

Your goal sounds like a seamless wireless network area when moving from near router to near repeater. Is there any way to run a CAT 5e cable from the router to the location of the repeater and use wireless AP mode rather than a repeater mode?
Score
0
January 22, 2012 10:13:05 AM

RealBeast said:
I assume that your AP has the same SSID and it uses a different pair of radio channels already. I would not use its DHCP server, just stick with the main router assigning addresses.


My Repeater automatically selects the same channel as the Router (for whatever reason) although when the system is working okay this does not seem to make a difference.

RealBeast said:
In the router DHCP server you should be able to reserve dynamically assigned addresses for specific devices by MAC address if that has been an issue. The other choice is to shrink the DHCP assignable range and use static addresses in the network range but outside the dynamic assignment range.


I will have a play with this...

RealBeast said:
Your goal sounds like a seamless wireless network area when moving from near router to near repeater. Is there any way to run a CAT 5e cable from the router to the location of the repeater and use wireless AP mode rather than a repeater mode?


I wish it were this simple :)  We are in a temporary office, and have had to hire another office across the carpark - a distance of about 20-25m. I would have used electrical socket networking, but the office is on a different power supply. There is no way to set up any wires from one side to the other.

I am trying to save on costs because the organisation is a not-for-profit organisation that is better off paying staff :) 

At this point it seems that setting up TCPIP/adapter settings on each client PC is the most enduring way to fix the problem - any suggestions of programmes to do this in Windows 7? Any ideas for other potential fixes?
Score
0
Related resources
Anonymous
July 14, 2012 10:23:39 PM

i'm in the same situation like you was.. did you fix this somehow? i was thinking instead of using the tp link as range extender, better make different wireless network but this was i just give up and dont like it.. :) 
Score
0
April 22, 2013 10:59:13 AM

Same issue here. I use a Thomson TWG870U (from UPC Ireland) and the same Repeater (TP Link WA830RE) and have exactly the same issues as described by the OP.

I will now try to disable both DHCP and just assign IP addresses to all devices, including mobile phones. The thing that I still don't understand is why my laptop apparently has no problems at all connecting but my Android phone constantly acts up when I move from the living room, where the router is located, to the bed room with the repeater.
Score
0
!