Sign in with
Sign up | Sign in
Your question

PSU trouble

Last response: in Systems
Share
January 29, 2013 7:03:49 AM

Hello Everyone,

My system:

Intel i5 3570K
AsRock Z77 Extreme 4
G.SKILL Ares Series 16GB (4 x 4GB)
EVGA GeForce GTX 670 FTW 2GB
Mushkin Enhanced Chronos 120GB SSD
Seagate Barracuda 1TB HDD

I recently had some trouble with my PSU which originally was an XFX PRO750W XXX Edition which I had to RMA back to XFX because one day I tried to turn on my computer and there was absolutely nothing that happened when I pressed the power button. Anyway, I ended up RMA(ing) the PSU to XFX and they told me that it was "FAULTY". They sent me a replacement which was XFX PRO750W Black Edition and I plugged everything in like a did with my previous power supply and pressed the power button. My computer did turn on and went through the POST, but for some reason my SSD/HDD/DVD-Writer were not getting any power. I checked my BIOS and none of them showed up and I even pressed the eject button on my DVD-Writer, but it wouldn't do anything. I double checked the cables connected to the PSU and to my drives, I checked the cables for physical damage, I tried connecting the cables to different spots on the PSU but nothing worked to power my drives.

On the flip side, when I do turn on my computer, the CPU fan and GPU fan spins, as well as the system fans that have to be connected to the PSU via a peripheral (4P) cable. Well, I tried for about an hour to figure it out, but no such luck. I ended up buying a Corsair GS800 from the store to see if maybe a completely different PSU would work, and it did. I connected the Corsair GS800 up to my computer and everything started up as it should and my system is up and running.

What am I doing wrong with the XFX replacement PSU? XFX did ask me to use a multimeter to test the PSU, but I don't really feel like buying a multimeter to use once. I mean, when I built my computer with my original PSU I didn't have any problems with the PSU and I didn't have to do anything extra to get it to work, why would the replacement be any different?

Well, sorry about the long post, but I'm hoping that someone can help me out here, and if you've read this far into the post... Thank you. :hello: 

More about : psu trouble

January 29, 2013 8:46:36 AM

Are you sure it's not your motherboard? To find out, you could try your PSU on another PC. Or have you tried resetting the motherboard, via the CMOS jumper?
And regarding the multimeter, you should get one, because you never know when you might need it.
m
0
l
January 30, 2013 7:51:13 AM

Thanks for responding, Walkingepidemic. I will try clearing the CMOS from the button on the motherboard and from the jumper to see if that might work. The last computer I own is about 7 years old, so I'm not even sure the power supply would work on a motherboard that old, but I'll look into that. So, I'll report back when I get some time to try this.
m
0
l
Related resources
a c 136 B Homebuilt system
January 30, 2013 8:10:28 AM

doesnt sound like the mb to me

have you tried a different cable?

have you also got the SATA cables plugged in?
m
0
l
January 31, 2013 7:49:40 AM

@Outlander_04 - Yes, I've tried different cables and also had the SATA cables plugged in and still nothing. I've tried clearing the CMOS (button and jumper method) and that didn't help with the problem. So, that's where it stands at the moment.
m
0
l
!