Sign in with
Sign up | Sign in
Your question

Toshiba Satellite P500-1JF will not boot

Last response: in Systems
Share
January 31, 2013 6:28:00 PM

Hey guys, I recently bought a Toshiba Satellite P500-1JF off of a friend, knowing that it wouldn't work and hoping that I could fix it as usually this would be no problem but I can't seem to get this laptop working. I cannot enter the BIOS or enter the boot menu. All that it displays is:
  1. CPU = 1 processors detected. Cores per processor = 2
  2. Intel(R) Core(TM) I5 CPU@2.67 Ghz
  3. Fixed Disk 0: WDC WD1200BEVS
  4. System Configuration data update


I bought the HDD separately as it did not have one when I bought it. It also does not show the splash screen and doing some research I think this is because some sort of fast boot mode is selected or something, any Ideas on how I can enter the bios or the boot menu so I can install windows?
February 3, 2013 3:44:54 PM

Hello bentodd :hello: 

Try resetting CMOS by unplugging it and taking the battery out then take the battery(small button battery may be connected by a jumper under the keyboard) out of the MOBO for a few minutes and replace it see if that works, this won't negate the need for a password but it will clear the classical CMOS parameters. After the power button is hit repeatedly hit F2 to get to the Bios then disable fast/flash boot in Bios if needed for ease of working on it. If that doesn't work it looks like you may need to take it in to get the bios reflashed. Looks like the bios on :pfff:  Toshiba machines is pretty flakey.

Just my 2 cents do with it what you will.
February 3, 2013 7:17:46 PM

Yeah, I actually pulled apart the laptop a couple of hours after I posted the question. And it did seem to fix it, although I managed to break the little clips around the CMOS battery so it's now duct taped in... but it completely works now. Thanks for the response anyway mate. :) 
!