Sign in with
Sign up | Sign in
Your question

How to force max clockspeed in game

Last response: in Graphics & Displays
Share
December 17, 2012 11:10:07 AM

Hello guys,

My new Radeon hd 7950 isn't performing on it's max clock speed in games. Sometimes it's gets to around 501mhz and than 950mhz on skyrim... And when i'm playing games like League of legends it's only at about 300mhz or 501 mhz with vsync on. (this greatly decreases my FPS) and when i turn vsync off i get around 950mhz and my fps goes to around 190.. Is there any way i can put my GPU always in maximum clock speed when i'm playing games?

thanks!
-redbadboy
a b U Graphics card
December 17, 2012 11:51:05 AM

ok your clocks will decrease with v sync. v sync caps your framerates coming out of the graphics at 60 fps which is your refresh rate of the monitor. if the card can produce 60 fps and not be fully utilized it will downclock itself for power and electricity. when you turn the v sync off the gpu is uncapped so it will pump out as much framerate as it can. if you want the gpu to work at maximum then dont turn on vsync in games
a b U Graphics card
December 17, 2012 11:56:52 AM

vsync limits your fps to your monitor's refresh rate, probably 60 Hz. Since you have a powerful card it doesn't need to work hard to get 60 fps in most games and will stay downclocked. I don't see a problem here.
Related resources
December 17, 2012 12:09:05 PM

The other thing you have to remember is that when you turn that VSync off you may see tearing.

If I turn off VSync is skyrim, that game is horrible for tearing, but I agree it is much better when the fps are high. But in a game like AC:3, I turn it off and don't get any tearing and the game looks great.
December 17, 2012 12:10:58 PM

The problem is, when i'm playing leauge of legends. And i set vsync on my frames sometimes go to around 40fps and i see my clock speed is going to around 300mhz to 501mhz.. which is realy anoying because it isn't very smoot anymore than.. When it should perform easy a 60fps stable with vsync on
December 17, 2012 12:18:35 PM

I realize this is unrelated because it's an AMD card but for you guys with Nvidia cards, check the power setting for the profile of the game in the Nvidia control panel. Make sure it is set to prefer maximum performance and not Adaptive. I noticed playing Deus Ex once that the game would run really well but from time to time it would struggle and slow down. I set a 3d monitor running and when it dropped in speed I switched to the monitor and noticed the Mhz of the GPU had dropped. Once set to prefer full performance it wasn't a problem.
December 17, 2012 12:21:40 PM

warezme said:
I realize this is unrelated because it's an AMD card but for you guys with Nvidia cards, check the power setting for the profile of the game in the Nvidia control panel. Make sure it is set to prefer maximum performance and not Adaptive. I noticed playing Deus Ex once that the game would run really well but from time to time it would struggle and slow down. I set a 3d monitor running and when it dropped in speed I switched to the monitor and noticed the Mhz of the GPU had dropped. Once set to prefer full performance it wasn't a problem.


True, but isn't there a option for amd gpu's for high performance mode.
!