Catalyst help

I am re-installing my Radeon drivers and want to know what do i need to get: Catalyst 12.11 or the 12.11 with .net4 support - which one do i need? does it matter?

OS: Windows 8 Pro 64 bit
GPU: Radeon HD 7970
1 answer Last reply
More about catalyst help
  1. you might as well download drivers with .net4 as all of the new games use it
Ask a new question

Read More

Radeon Catalyst Graphics