Sign in with
Sign up | Sign in
Your question
Solved

Wireless and Wired not playing nice

Last response: in Networking
Share
January 21, 2012 5:00:33 PM

Quick N Dirty:
My Wireless connection will not coexist peacefully with my wired private network. They seem to be mutually exclusive.

Problem:
I have 2 networks that I'm trying to work with. I have a wired home network that does NOT have internet connectivity as well as a wireless adapter that I use to get to the internet through a secondary router.
When I have the LAN connected I can see the internet connection but cannot use it for anything. All web pages time out.
I have the Secondary router on 192.168.1.1 and Primary router on 192.168.2.1 and am getting separate addresses from each so I don't think there's a conflict in IP addresses.
I have tried this on Windows 7 32 and 64 bits with no difference so I don't think it's OS related.
I am tired of having to unplug or disable the adapter when I want to go online.
If possible, I would like to be able to have all machines share the internet connection without having the private network exposed to the outside world.

Background:
I use my primary as a home network and can only access the secondary network through a WOK-FI (google it. Amazing stuff) to access my neighbors router (Yes, I have permission) so I can't just put my primary router in repeater mode (That would've made things alot easier). So, now I'm stuck with attempting to share my WOK-FI access with the rest of my house. I have done about 3 hours of research only to find tons of posts about trying to bond their connections to get faster throughput (not my case).

What I have:

Home Network
(PC1) ---> (PRI.ROUTER) <~~~ (PCn)

Public Network
(PC1) ---> (USB) ~~~> (SEC.ROUTER) ---> (INTERNET)

What I want (if possible)
(PCn) <~~~> (PRI.ROUTER) <--- (PC1) ---> (USB) ~~~ (SEC.ROUTER) ---> (INTERNET)

Netgear WNDR3300 Router (PRI.ROUTER)
Alternate Router (SEC.ROUTER)
Netgear WDNA3100 Wireless USB Adapter (USB)
My computer (PC1)
Wireless netbook + son's PC + other PC's (PCn)
--- wired
~ wireless


Thanks in advance people
a c 202 F Wireless
January 21, 2012 8:56:51 PM

You should be able to easily bridge the two networks in Windows 7. On a Windows 7 machine that has access to the Internet and is also on the wired network, just open the Network and Sharing control panel, change adapter settings, and select the two and then do THIS to bridge the two networks. After the bridge, both the wired and wireless will share the Internet.
January 21, 2012 11:21:27 PM

Thanks for the input RealBeast. I thought that would be the way to do it but I still have the original problem . . . I can't seem to stay connected to the wireless once LAN is established. Plug LAN in or turn it on and <poof> no more wireless connection. I can see the wireless connection and see that it is connected but all traffic ceases.
Related resources
a c 202 F Wireless
January 22, 2012 11:59:45 AM

Double check all the settings and make sure that the wired and wireless networks are actually using different network addresses, DHCP assignment ranges, and gateway addresses and that they are correctly paired to the particular network card, sounds like a network conflict if the wireless disappears when the LAN comes on.

Also, check your attachments to the routers -- which ports on the routers are you using to make connections for each network. I don't see where you would use the WAN port on either the way I understand your configuration, but rather all to LAN ports.
January 22, 2012 4:20:16 PM

Thanks for the continued help.

OK I got the 2 networks working independently. Turn out I had to set the LAN manually with a static IP and leave "Default Gateway" and "DNS Server" fields blank. Now I am connected with my local LAN and I can connect to the internet through the wireless adapter. Wireless assigns 192.168.1.x and LAN is manually set to 192.168.2.x
So far so good. :) 

Now the problem is getting the two bridged. As soon as I bridge the connections, I lose all connectivity and can't see local network OR internet. :( 

I'll just be here until 2:00 AM again trying not to pull my hair out.
a c 202 F Wireless
January 22, 2012 5:13:57 PM

Do you get any error message when you select bridge network?

Does the network bridge show up in the Network Connections window after you select bridge? In the bridge properties does it show the correct networks checked as bridged and all the clients and protocols checked? Also try right clicking on the bridge icon and select diagnose to run the networking troubleshooter, which will sometimes help.

Also do you have Internet Connection Sharing turned off and the Windows firewall disabled?
January 23, 2012 1:19:28 AM

OK. Problem solved. Thanks a TON RealBeast.

Here's exactly what I did to make it work (in case someone else is reading this)

1. Changed my router to different subnet: 192.168.2.1 and left DHCP on. (not sure if this was necessary)

2. Set the LAN connection on my PC manually and set IP4 address to 192.168.2.5 and subnet 255.255.255.0 while leaving "Default Gateway" and "DNS Server" fields blank.

3. Bridged connection like RealBeast suggested earlier.

4. Here's the kicker: REPLACED THE LAN CABLE GOING TO MY ROUTER and plugged the cable into the WAN port on the router. (You'd be surprised that one of the simplest things could be source of all my headaches, not to mention lost hair.)

5. Restart router and let it do it's startup thing.

6. Write this post
January 23, 2012 1:29:20 AM

I used the WAN port on the router because the internet is going through my PC before it gets to the router, essentially turning my computer into the modem as far as my router is concerned. The router then acts like a, well, a router to assign addresses for all the wireless devices and forward internet accordingly.

Only one problem remains:
My PC is now outside of the network on either end. I can't see the other computers on the other side of my router.

Thought:
Would moving the cable from WAN to LAN solve the "odd man out" syndrome? I suppose I could build a dedicated computer to be the "odd man out" but would rather clean it up without doing that.
a c 202 F Wireless
January 23, 2012 11:51:48 AM

Yes your PC should be on an LAN port not the WAN.
January 23, 2012 6:55:21 PM

OK. I tried moving cable from WAN and plugged into LAN side on router.

Result: Wireless clients can't see internet anymore. While plugged into LAN port, I can see all wireless and (now) wired computer under "attached devices" in 192.168.2.1 (router). Man-in-the-Middle can has internets regardless cuz its bridging the connection.

I'm now wondering if ICS is the way to go with an ad-hoc on the LAN side.

tag . . . you're it!
a c 202 F Wireless
January 23, 2012 7:21:41 PM

Not sure if you can use ICS and bridge a network that uses it, you couldn't in XP but I have not actually tried it since then.

Hmm, seems odd but yo obviously must use the WAN for some inexplicable reason. It still makes no sense to me that the computer bridging the networks does not see the Internet. I'll have to think about that one.
January 23, 2012 8:24:32 PM

So far Here's how it looks:

(all wireless clients)<~>(router)<--wan port to onboard lan-->("MITM" bridge with wireless adapter)<~>(neighbors router)<->(nirvana)

So, as soon as I take WAN and connect it to LAN on the router, wireless clients can't see Nirvana. Man-in-the-Middle can get to the internet always anyway because it's providing the bridge, but my gf and son can't experience Nirvana.

Plug it back into WAN port on router and the internet light on the router lights up like christmas and everybody is happy. Well almost. I'm not happy because MITM is the file server for everyone else and now I can't see any of the wireless clients because they're protected by the router and MITM looks like "big bad meanie haxor dood from the internet"

Talk about biting the hand that feeds.
January 23, 2012 8:32:15 PM

I know that I'm basically turning my PC into a wireless bridge (sounds just like what putting a router into repeater mode is) and making this alot harder than I actually should be but, I would like to get this thing figured out without just running over there and configuring my neighbors network.

I also don't think reconfiguring their network would work because I MUST the "wok-fi" since my router can't see theirs. My neighbor is 3 houses away from the FAR end of the house.

And again, thanks Beast for being the only one to lend a hand. . . . so far

Best solution

a c 202 F Wireless
January 23, 2012 9:07:30 PM
Share

I would probably just sit back and enjoy the fruits of your labor and accolades from the family for a while, but in the future you could consider buying a hardware bridge so you don't have to use your computer for a software bridge.
January 23, 2012 9:19:25 PM

Thanks for all the help. I'll keep this thread open for a while and see if anyone else has any other ideas. God knows I've picked your brain enough. You've been a godsend.
January 27, 2012 4:15:34 PM

Best answer selected by landran.
February 8, 2012 3:28:29 AM

I have been searching for this for a long time. My experience is similar to Indran's except that I am using Xfinity wifi to connect to Internet. The setup is exactly same. 3 computers hardwired to a private local network. Each one has a wireless card built in. I can connect to Xfinity as long as the wire is not connected. As soon as the wire is connected, the wireless connection status goes from "Local and Internet" to "Local Only". The moment I disconnect the wire it goes right back to "Local and Internet". I need to see internet as well as the other computers.
a c 202 F Wireless
February 8, 2012 8:34:18 PM

You can bridge your network as he did.

You can also change the priority order of Internet connections for a machine that has more than one choice. The default is usually to the wired Ethernet port. That can be changed in Network connection -- hit the alt key then select advanced from the file menu choices and next advanced settings. Then just highlight a connection and hit the up/down arrow to move it in priority.
!