Sign in with
Sign up | Sign in
Your question
Closed

SLI 680's on far cry 3

Last response: in Graphics & Displays
Share
December 18, 2012 2:23:48 AM

I have 2 GTX 680's and when I play Far Cry 3 on max settings it skips around more than a little school girl... Is it normal to have such a choppy frame rate? I've already verified that SLI is enabled, both GPU's are working but they are maxing out even on a single display... Resolution is 1920x1080.

any feedback is appreciated

Thanks
-Chase :pfff: 

More about : sli 680 cry

a c 171 U Graphics card
December 18, 2012 2:34:47 AM

what cpu do you have. you need a really powerful cpu to keep up with those vid cards. and what motherboard, your not running one of the cards in a 4x slot are you? and power supply/ maybe not getting enough power. and then there is microstuttering, which can be fixed if you induce a frame rate cap to the lowest expected fps.
Score
0
December 18, 2012 5:46:34 AM

850 Watt corsair power supply and an FX-8150 overclocked at 4.6GHz... The CPU will be replaced in a few weeks with a 3770k and the motherboard will be swapped with a Sabertooth x79 I believe it's called. Still it's the GPU's bottlenecking not the CPU.
Score
0
Related resources
a c 171 U Graphics card
December 18, 2012 6:26:46 AM

maybe a driver issue, or game issue that will be patched soon enough.uninstall the nvidia drivers and reinstall the latest ones.
Score
0
a b U Graphics card
December 18, 2012 7:53:37 AM

Nvidia have had SLI issues which I believe were fixed in the last driver update. Not sure, try that.
Score
0
December 21, 2012 7:14:41 PM

With 2 680's and a 3770k should I be able to play on ultra settings with 3 monitors? or would that require a 3rd card?
Score
0
a c 79 U Graphics card
December 21, 2012 7:21:10 PM

2 680s should work fine in tri-monitor setup, also if the games cpu depedant as well, a 3770 would give u optimal performance but depands if u can afford a new mobo+cpu setup.

Score
0
December 27, 2012 5:08:06 PM

CPU got shipped in yesterday, ill have to wait for my next paycheck before purchasing the new motherboard, will keep everyone updated
Score
0
December 27, 2012 5:58:21 PM

3 monitors would be kind of limited by 256bit bus of 680s

best
revro
Score
0
December 28, 2012 5:40:55 AM

Second half of the video. Do that and most problems should be gone. I'm only on a GTX 650 Ti and a AMD Phenom X4 2.3Ghz and I can play on Ultra DX11 with hardly any stuttering. I was getting choppy performance before I changed the driver settings to the ones in this video. Hope it helps.
http://youtu.be/9AFV4Me308w
Score
0
December 28, 2012 6:38:01 AM

Farcry3 has notorious frame skipping issue.Its the engine fault.Only fix is setting frame buffer to 1 or disable SLI.Its even worse on AMD crossfire setups.
Score
0

Best solution

December 28, 2012 12:50:26 PM

First of all , you said your getting a i7-3770k , you need to understand that this is a LGA1155 socket so a x79 board WILL NOT WORK. Get the Sabertooth Z77 instead of X79.

Then with 2 GTX 680 SLI , and a i7-3770k. You should experience better performance. If there is a need , try overclocking your i7-3770k , make sure to get a good heatsink before overclocking.

If your intending to game on tri-screen , 2 GTX 680 would be more than enough unless you really want super high frame rate. Where a 3rd card would matter but usually SLI with 2 cards is enough for triple screen gaming.
Share
December 31, 2012 2:51:01 AM

Already have a an h80 watercooler, and yes I will be getting the z77 motherboard
Score
0
December 31, 2012 7:41:08 AM

BigMack70 said:
The fix is:

Vsync enabled (in-game to 1 frame)
GPU Max Buffered Frames = 1
+
use MSI Afterburner to set the framerate limit to your refresh rate [<-- most important part]


That completely removed stuttering on my 7970 CF setup at both 1080p and 1440p resolution. Not sure if it works on all setups or not, but it's worth a shot.

+1 Although just turning off Buffered Frames entirely is probably better. I'm not sure if it put my 650 Ti over with the 1 frame buffer but it did cause a few to drop.
Score
0
January 1, 2013 5:52:41 AM

BigMack70 said:
Interesting; setting max buffered frames to 1 definitely helped eliminate stuttering for me but I didn't measure its affect on average fps as I'm at 60 constant anyways.

Either way, I think that if you're experiencing stuttering you can play with things and get rid of it in the game.

I think frame buffer was an issue for nvidia cards. I see your using Radeon cards so it might not apply to you. Don't quote me on all that though.
Score
0
January 11, 2013 1:02:41 AM

Best answer selected by cdjuda.
Score
0
!