Sign in with
Sign up | Sign in
Your question
Closed

Win8 - Radeon HD 5870 won't take drivers

Last response: in Graphics & Displays
Share
December 20, 2012 1:20:11 AM

Hi All,
I Just installed a Sapphire Radeon HD 5870 1gb OC edition and I can't for the life of me get Catalyst installed.
Device manage shows the 5870 there with the error symbol and Catalyst installed fine.
On reboot I get an error in windows saying:
"No AMD Graphics driver installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware."

Will Catalyst 12.11 not work with it? It's what the Sapphire website gives me to download.

I'm stuck, please help. Thank you.
December 20, 2012 1:27:23 AM

try downloading straight from amd's site. i also believe windows update will offer you a driver download though it wont be the newest one.
Score
0
December 20, 2012 1:34:06 AM

jonjonjon said:
try downloading straight from amd's site. i also believe windows update will offer you a driver download though it wont be the newest one.


Windows update tells me the driver is up to date but then tells me the card isn't using any resources because it has an issue.
I downloaded 12.11 from AMD's site and still got the error.
Score
0
Related resources
December 20, 2012 1:49:39 AM

Ok I just tried installing Catalyst 12.10 and same issue.
Here is what windows is telling me under device status

"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

{Unable to Load Device Driver}
%hs device driver could not be loaded.
Error Status was 0x%x"
Score
0
December 20, 2012 1:56:38 AM

did you try uninstalling the drivers. rebooting and reinstalling.
Score
0

Best solution

a c 108 U Graphics card
a b À AMD
December 20, 2012 2:25:20 AM

Glad you got it fixed and will take a bookmark of that site. I have used Win8 with my 5870 and it was fine. At least if I run into issues, I can try what you did.
Share
December 20, 2012 6:18:22 PM

Best answer selected by ibjeepr.
Score
0
!