New Sapphire 7850OC crashes in games

Hello,
Intel Core i3-3220, Dual Core, 3.30GHz, 3MB, LGA1155, 22nm, 55W, VGA, BOX
MSI MB B75 S1155 MATX/B75MA-P45 2xUSB 3.0, SATA3.
Samsung 24x8x DVD+RW/ 24x6x DVD-RW MUST+ 12x DVD-RAM, SATA Bulk, DL
Kingston 8GB 1333MHz
Chief BD-02B-B-OP matx case
SeaSonic S12II series 620W 85+ (Bronze) S12II-620
SAPPHIRE HD7850 2GB GDDR5/OC PCIE16
WD Blue HDD SATA 1TB 7200RPM 6GB/S/64MB WD10EZEX

I have tried Far Cry 3 and Heaven DX11 and something crashes early on. In far cry sometimes it happens when i start changing my graphics setting, sometimes it last as long as Vas starts to talking in introduction.
Monitor shuts down but computer is still running (cant to anything of course), fans are running.
I have tried uninstalling all drivers and install again (catalyst), still the same problem.
Running Furmark for 7 minutes gave (did not crash): CPU usage 99%, fan 48%, temp 61'c
Seems to play 1080p videos correctly.
Don't really know what to do, hope someone could help. Idle temperature is around 30 and just before it crashed in Far Cry 3 temp was 45-50 if i recall correctly.

EDIT: I starter the whole 15 minute process in Furmark and same thing happened around 14 minute mark, temp was 71 'c.
With passmark performance test the same thing happened, so it seems that the problem is definitely in GPU, but how serious is it ? Is the card broken or is it some soft error ?
5 answers Last reply
More about sapphire 7850oc crashes games
  1. try use driversweeper...the old driver stiil remain becasue you are not fully remove.,but must use the driver sweeper in safe mood..
  2. I used this tutorial for removing everything, i dont think that the problem lies there.
  3. I runned Furmark again, it crashed at one point, temp was 73-74 'c but monitor did not turn off, displayed white-blue vertical lines over a screen instead.
    Then I tested bioshock demo with low settings at 720p resolution, at the moment of crashing temp was 52 'c; 2050 RPM and 64% (fan); core clock 920 MHz; memory clock 1250; 1,138V; memory usage dedicated and dynamic 162 MB and 172 MB.
  4. Your temps look normal, it could be a defective card.

    But just in case did you check the temps of other components as well? Benchmarks and games can make the CPU work a lot too. It could also be a software problem (aka drivers) but it doesn't seem like you did anything wrong, do you have access to another computer in which you could test the card? Otherwise if it's not too much trouble you could also try to reinstall Windows from scratch and see if you run into the same problems. Also, you didn't mention if you tried with different drivers? Try with a newer beta version or maybe an older stable version.

    But at first glance the no.1 suspect is a hardware problem. Good news is that since the 7850 is a recent card it's most probably still under warranty so you shouldn't have any problem to RMA it.
  5. Just went through with a format c, fresh W7 and latest catalyst, same problem.
    I have also tried different drivers (including latest beta).
    Also did CPU stress test with OCCT, no problems there, temps are nicely around 50 'c (48-50).
Ask a new question

Read More

Radeon Graphics