Sign in with
Sign up | Sign in
Your question

GTA4/General Gaming Issue

Last response: in Graphics & Displays
Share
December 20, 2012 8:39:12 PM

Hi,

Firstly I just wanted to say I'm not complaing about how well GTA4 runs on my computer, I've done hours of research and understand how it was a badly ported game and so on.

But I have some questions about my first home built system that have arisen from trying to get GTA4 to work. I've seen plenty of videos on youtube of GTA4 running on way worse systems than mine, however it literally will not run, even with the worst possible settings. I barely get 20fps with the in game benchmark tool, with everything as low as possible.

Here is my system specs:
CiT Black Ops Case & 500w psu
Gigabyte Z77-DS3H
Intel i3 2120 3.3ghz
8gb Corsair Ram
Asus Radeon HD6670 2gb GPU

I understand an i3 is not ideal and may bottleneck the system, and GTA really needs quad core, although surely not to such an extent that it refuses to work? I'm also starting to doubt the Asus graphics card, and whether its drawing far too much wattage from the motherboard (it has no external power)/generally a poor quality card.

What would you say I should change/test first in order to achieve better results?

I have updated all the latest drivers and such, but to avail. Again I'm not asking you guys to fix GTA for me, just asking whether you can see any issues with my system/things you'd change.

Cheers
Harry
a c 134 U Graphics card
December 20, 2012 8:51:24 PM

Well the 6670 isn't a amazing card to begin with its more of a entry level card for gaming. So I can see how that could possibly hold you back. Although as low as possible seems a bit weird. Your card if its not drawing additional pci-express power will more likely then not be causing a power issue. The game is great on the PC but as you said its not a perfect pc port I found the DLC's more fun personally.
m
0
l
a c 291 U Graphics card
December 20, 2012 8:53:06 PM

Your description seems constructive and informative. However, you seem to forget to tell us what's wrong exactly :) .
m
0
l
Related resources
a c 134 U Graphics card
December 20, 2012 8:55:38 PM

i think hes trying to figure out whats wrong with his computer giving him the performance it is 20 fps isn't a impressive feat on low settings in gta IV. So one could say well his CPU isn't as powerful as most who game and same goes with the Graphics card.
m
0
l
December 20, 2012 9:00:11 PM

@bigshootr8 I think I'm going to replace the graphics card, thanks for the advice.

@sunius/bigshootr8, Apologies! I just can't figure out what is causing the terrible performance. It really is the worst possible settings, and I just thought there must be something bigger wrong rather than just how badly GTA was ported.

I also have this weird glitch, after like 10/15mins of trying to play the game it will freeze, the sound will begin to stutter, I can only describe it as a duhduhduhduh but really fast, and then the game will continue to work (but lagging terribly as always). Even after shutting down GTA the sound continues till I restart the computer. Could that be an associated problem with a graphics card?
m
0
l
a c 291 U Graphics card
December 20, 2012 9:10:39 PM

Okay did you patch the game?
m
0
l
December 20, 2012 9:13:32 PM

It's currently running 1.0.7.0 from steam
m
0
l
a c 134 U Graphics card
December 20, 2012 9:14:31 PM

Maybe the stuttering would possibly be the video card its truly hard to say. Depending on your budget something like a 7850 would do wonders with GTA IV what PSU are you using I'm guessing it game with the case?


In terms of patching yea I thought as much thought you had it on steam.

http://www.youtube.com/watch?v=jjWO_rflu0E
m
0
l
December 20, 2012 9:23:48 PM

The PSU is the one that came with the case yeah. Would that graphics card work well with an i3?
m
0
l
a c 134 U Graphics card
December 20, 2012 9:31:16 PM

Your CPU should be more then enough it wouldn't be bottle-necked with your Sandy Bridge i3. The only concern I have is your PSU. What is the labeled 12v rail amps/Watts (should be labeled under the 12v). I don't particularly care for cases that come with PSU's normally they aren't great.
m
0
l
a c 134 U Graphics card
December 20, 2012 9:53:36 PM

14 AMPS on the 12V RAIL (JESUS!?!?!?!?!?!?!??!?) Yea I would get on that before upgrading a GPU ><

What happens when you turn the settings up does your performance take a nose dive you aren't using much of your vram.
m
0
l
December 20, 2012 10:05:26 PM

haha im guessing that could be the problem then. sorry for sounding completely stupid but could you explain why that would have a drastic effect on the games performance?

could you recommend a good psu upgrade thats not too pricey?

turning the settings up (in game) just kills it completely.

m
0
l
December 20, 2012 10:07:47 PM

My PC is very similar to yours actually, i3 2100 with a 2GB DDR3 6670 and 10GB of ram..
I play GTA IV and I get about ~35 avg fps on med-low settings, with a min of 20 fps.. Do your fps hover over 20 or below?
m
0
l
a c 134 U Graphics card
December 20, 2012 10:08:53 PM

No problem well it wouldn't have an effect really on performance well I take that back it may. Basically what the 12v powers is the PCI express lanes among other things. So moving up in graphic cards will be very difficult considering how your PSU's 12V output is so low.

I most certainly can suggest a PSU that isn't much.
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

And that is a bummer because you definitely have the ram for it you just don't have the horses
m
0
l
December 20, 2012 10:16:17 PM

@thymanbearpig the in-game benchmark said i was averaging 24fps, but thats at very best. 99% of time its far less than that.

@bigshootr8 thank you, looks like im upgrading my psu!
m
0
l
a c 134 U Graphics card
December 20, 2012 10:27:11 PM

and after the psu harry a new gpu :D 
m
0
l
December 20, 2012 11:10:17 PM

I found the benchmark to be more exact..
Quote:
Statistics
Average FPS: 38.00
Duration: 37.90 sec
CPU Usage: 71%
System memory usage: 30%
Video memory usage: 33%

Graphics Settings
Video Mode: 1280 x 720 (60 Hz)
Texture Quality: High
Shadow Quality: Medium
Reflection Resolution: Medium
Water Quality: Medium
Texture Filter Quality: Tri-Linear
Night Shadows: Off
View Distance: 25
Detail Distance: 24

Hardware
Microsoft Windows 7 Ultimate

Video Adapter: AMD Radeon HD 6670
Video Driver version: 8.17.10.1151
Audio Adapter: Speakers (Realtek High Definition Audio)
Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz

File ID: Benchmark.cli


I don't know a lot about troubleshooting, but I've heard of switching the video card to another slot, I'm not sure if that'd be worth a try.
m
0
l
December 21, 2012 4:27:19 PM

Below is my benchmark from the game.

Quote:
Statistics
Average FPS: 24.23
Duration: 37.14 sec
CPU Usage: 34%
System memory usage: 37%
Video memory usage: 23%

Graphics Settings
Video Mode: 800 x 600 (60hz)
Texture Quality: Low
Shadow Quality: Off
Reflection Resolution: Off
Water Quality: Low
Texture Filter Quality: Tri-Linear
Night Shadows: Off
View Distance: 2
Detail Distance: 2

Hardware
Microsoft Windows 7 Home Premium
Service Pack 1
Video Adapter: AMD Radeon HD 6670
Video Driver version: 7.14.10.304
Audio Adapter: Realtek HDMI Output (ATI HDMI Audio)
Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz

File ID: Benchmark.cli


I've noticed my video driver version is much less than yours? Yet everything tells me im up to date. Also my CPU usage seems very low.
m
0
l
a c 134 U Graphics card
December 21, 2012 6:33:47 PM

I would go to AMD's website and get the latest catalyst suite/driver.
m
0
l
!