Sign in with
Sign up | Sign in
Your question
Closed

warcraft 3 directx

Last response: in Windows XP
Share
March 6, 2005 1:07:01 PM

Archived from groups: microsoft.public.windowsxp.games (More info?)

when trying to run warcraft 3 it comes up "install directx 8.1 or higher" i
have the latest version of directx yet the problem still occurs, can someone
please help??

More about : warcraft directx

Anonymous
March 6, 2005 4:52:05 PM

Archived from groups: microsoft.public.windowsxp.games (More info?)

Hi Michael,

If you click Start / Run and type: dxdiag
What version of DirectX does it show as installed?

--
Cheers, Windows XP MVP Shell / User
Jimmy S. http://mvp.support.microsoft.com

Game FAQs: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
Visit my MSN Zone.com and Gaming Help Site: http://mvps.org/nibblesnbits
MS Assisted Support: http://support.microsoft.com/select/?target=assistance
My advice is donated "AS IS" without warranty; nor do I confer any rights.
_________________________________________________________

"michael" <michael@discussions.microsoft.com> wrote in message news:D AACAA86-71B2-4557-B4C0-76522CFD6B69@microsoft.com...
> when trying to run warcraft 3 it comes up "install directx 8.1 or higher" i
> have the latest version of directx yet the problem still occurs, can someone
> please help??
May 7, 2009 6:22:35 AM

I am haven the same issue and it has something to do with ATI and its drivers with directx from what ive found i have tried reinstall directx reinstall war3 running in compatibility and admin tried all kinds of combinations of compatibility but problem is still kicken my a** and ive had the game running on this system so i know its possible but while running it cant load some maps and will just freeze during others. so incase it helps ima give my specs and see if we all cant gather up info so we can get a work around or a patch for this and btw from what ive seen those that have had this problem its only with ATI cards.

My Specs.
Windows 7 x64 RC 7100
AMD Athlon64 x2 +3600 O.C. 2.6Ghz
2gig 533Mhz Ram
XFX GeForce 8200 MotherBoard
ATI 3650 512MB GDDR3

Graphics Software:
Driver Packaging Version 8.60-090316a1-078303E-ATI
Catalystâ„¢ Version 09.4
Provider ATI Technologies Inc.
2D Driver Version 8.01.01.888
2D Driver File Path
/REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0001
Direct3D Version 8.14.10.0655
OpenGL Version 6.14.10.8577
Catalystâ„¢ Control Center Version 2009.0317.2131.36802


This should be specific enofe to help... ^^
Related resources
Anonymous
November 5, 2009 6:36:46 PM

When i'm going to play war 3 it says that I don't have installed directX 8.1 or newer ,but ihave installed the latest version please someone help me if i don't play this game i will die!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
November 16, 2009 3:43:22 AM

I am having the same problem as you all.

I am using Windows 7 with an 8800gts by nVidia.

You can find a copy of my dxdiag here: http://www.saiori.net/DxDiag.txt.

Any thoughts would be extremely helpful. I've tried all of the following:

  • Re-install both games (4 times now), from both my disks and digital download from battle.net
  • Verify that I have the latest version of DX (11)
  • Verify I have the newest drivers from nvidia.

    Thanks again for any input you might have for me.

    Jacob

    April 10, 2010 7:34:06 AM

    :(  BAD BAD BAD I FOUND OUT THAT WINDOW7 DOES NOT SUPPORT WARCRAFT 3 SO BAD LUCK saiori. Me Myself are using window 7 i found out when i tried reinstalll warcraft 3 it says window 7 does not support warcraft 3....... :(  :(  :(  :(  :( 
    Anonymous
    April 25, 2010 8:13:10 AM

    Hi I am Mysteryguitarboy (LOL)

    Jay or anyone that has a problem on opening warcraft 3 I have finally find the solution on our problems.

    After 16 hours of re installing warcraft 3, download an system optimizer, download any program in order the game will play, even reformatting my PC.

    I just found out that the answer of the problem is so easy and don't really need to do all the kinds of stuff above. It just need only a little adjustment on system.

    First you open START then open RUN then type DXDIAG then Directx diagnostic tool will appear then go to display.

    Below display there is Directx Features. Enable the Direct draw Acceleration.

    Then TADA! you can play your warcraft now. I hope it can help your problem.


    BTW This is my
    System Information
    ------------------
    Time of this report: 4/25/2010, 15:06:42
    Machine name: XPWINDOWS7
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp.080413-2111)
    Language: English (Regional Setting: English)
    System Manufacturer: ECS
    System Model: G31T-M7
    BIOS: Default System BIOS
    Processor: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz (2 CPUs)
    Memory: 1024MB RAM
    Page File: 736MB used, 1725MB available
    Windows Dir: E:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.5512 32bit Unicode

    If ever anyone is still confused Try to email me or chat at mike_ron99@yahoo.com
    July 2, 2010 7:28:40 AM

    but how to enable directdraw accelaration?
    July 2, 2010 8:09:30 AM

    how to enable directdraw accelaration?
    August 26, 2011 9:57:27 PM

    This topic has been closed by Mousemonkey
    !