Sign in with
Sign up | Sign in
Your question
Closed

"Local Area Connection"doesn't have a valid IP config

Last response: in Networking
Share
January 24, 2012 6:47:25 PM

Yesterday my internet (Via Cable) was working fine on my desktop, today it keeps telling me
"Local Area Connection" doesn't have a valid IP configuration. My W-Lan works fine, I've replaced the cable with another cable, restarted everything five times over, and even tried plugging the computer directly into a wall.

***When I connected my laptop via cable (tried several) It gave me the same error...?

Is there a problem with my router?

Help!!
January 24, 2012 6:57:14 PM

What do you mean by plugging your cable directly into a wall? What is the overall network setup you are working with?

One quick test to make sure the cable, and machine are good is to hook the laptop up to the Ethernet port on the cable modem, then reboot the cable modem and see if the laptop is working (disable wireless on the laptop). That would at least let you know the problem is with your router, and you're working with a good cable/nic on the laptop. I just suggest doing that with the laptop as its probably easier to move to wherever your cable modem is.

Assuming that works fine, hook the modem back up to your router and reboot the cable modem. Then log into your router and check the dhcp settings.
Score
0
January 24, 2012 7:02:39 PM

tomatthe said:
What do you mean by plugging your cable directly into a wall? What is the overall network setup you are working with?

One quick test to make sure the cable, and machine are good is to hook the laptop up to the Ethernet port on the cable modem, then reboot the cable modem and see if the laptop is working (disable wireless on the laptop). That would at least let you know the problem is with your router, and you're working with a good cable/nic on the laptop. I just suggest doing that with the laptop as its probably easier to move to wherever your cable modem is.

Assuming that works fine, hook the modem back up to your router and reboot the cable modem. Then log into your router and check the dhcp settings.


First things first, I dont have a modem I am aware of. I live in a student accommodation, and we each have our own internet connection (usually just plug into the wall and you have internet). I bought a router for Wlan a while ago, but have had no problems with it until now. If its the modem that is the problem, I have no idea where it is.
Score
0
Related resources
January 24, 2012 7:08:52 PM

Thanks for adding the additional info.

Are you certain the wireless network that you are connecting to is the network you setup coming from your router? Try logging into the router interface and make sure it has an external IP address, and verify you can see your laptop is connected to it in the dhcp client list. It's possible you are connecting to someone else's wireless, and the port in your wall is not working at all. If that's the case hopefully there is some campus support offered that could help you further, as there likely isn't much you can do if the port itself isn't working.
Score
0
January 24, 2012 7:11:40 PM

tomatthe said:
Thanks for adding the additional info.

Are you certain the wireless network that you are connecting to is the network you setup coming from your router? Try logging into the router interface and make sure it has an external IP address, and verify you can see your laptop is connected to it in the dhcp client list. It's possible you are connecting to someone else's wireless, and the port in your wall is not working at all. If that's the case hopefully there is some campus support offered that could help you further, as there likely isn't much you can do if the port itself isn't working.


Im positive that my internet connection is mine, im the only one here with wireless internet. And about connecting to the Router, i've never done that before... how do you do it? :S
Score
0
January 24, 2012 7:14:29 PM

Depending on the router you would open your web browser and go to 192.168.1.0 or 192.168.0.1 or something similar to that. If you google how to connect to your router it should come up pretty easily, or you can post the make/model of it here.

Once you get that webpage up you would need a login/password, but if you haven't connected to it before it should still be the defaults it shipped with which is also pretty easy to google for.

If you still have any of the documentation that came with the router all of the above will be in that as well.
Score
0
January 24, 2012 7:17:20 PM

tomatthe said:
Depending on the router you would open your web browser and go to 192.168.1.0 or 192.168.0.1 or something similar to that. If you google how to connect to your router it should come up pretty easily, or you can post the make/model of it here.

Once you get that webpage up you would need a login/password, but if you haven't connected to it before it should still be the defaults it shipped with which is also pretty easy to google for.

If you still have any of the documentation that came with the router all of the above will be in that as well.


I bought the router 2nd hand, So i wasnt the one to configure it. The router is an Air:Link 29150 from Jensen Scandinavia.

I also just connected another computer to the router, tried it via. Lan, to no avail. Then I took the cable connected to my desktop and connected it to the connection of the girl living next door (I have a long cable) still no success...
Score
0
January 24, 2012 7:24:06 PM

Well you could try resetting the router to defaults, although it's very possible that would stop your wireless from working until you were able to login to the router and reconfigure things.

If you wanted to try resetting the router there should be a very small hole somewhere on it that you push a paperclip into while the router is powered on. Hold the paperclip for 5 or 10 sec until you see the power led start flashing on the router. It will take a few minutes for it to reboot itself, but that may fix the problem.

If you tried connecting your laptop to your neighbors lan port which is known to be working, its possible your campus blocked your machine from their network, and no amount of troubleshooting will get it working again until you contact campus support and see what the reasoning is. Although theoretically it should actually still connect from behind your router assuming the router was working properly.

I'm sorta out of ideas here other then contacting someone on campus, but maybe another forum user will chime in.
Score
0
January 24, 2012 7:28:42 PM

tomatthe said:
Well you could try resetting the router to defaults, although it's very possible that would stop your wireless from working until you were able to login to the router and reconfigure things.

If you wanted to try resetting the router there should be a very small hole somewhere on it that you push a paperclip into while the router is powered on. Hold the paperclip for 5 or 10 sec until you see the power led start flashing on the router. It will take a few minutes for it to reboot itself, but that may fix the problem.

If you tried connecting your laptop to your neighbors lan port which is known to be working, its possible your campus blocked your machine from their network, and no amount of troubleshooting will get it working again until you contact campus support and see what the reasoning is. Although theoretically it should actually still connect from behind your router assuming the router was working properly.

I'm sorta out of ideas here other then contacting someone on campus, but maybe another forum user will chime in.



Okay, so heres the latest on whats happening:

I connected my 3rd laptop via cable - it worked.

I connected the laptop that didnt work earlier via cable - it worked

I connected the desktop (the only thing that doesnt have wlan and thus needs cable) - didnt work. same problem as always.... Im at a complete and total loss of what is going on.

Also, the university has no say in my internet, its via the landlord, so they cant block my machine.

any ideas?
Score
0
January 24, 2012 8:14:15 PM

Open up a command prompt and type "ipconfig /all" post the results for your Local Area Connection here.

Should be something similar to:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 00-1F-D0-DA-9B-4F
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.0.0.113(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, January 19, 2012 6:53:00 AM
Lease Expires . . . . . . . . . . : Friday, March 01, 2148 11:40:59 PM
Default Gateway . . . . . . . . . : 10.0.0.1
DHCP Server . . . . . . . . . . . : 10.0.0.1
Score
0
January 24, 2012 8:22:04 PM

tomatthe said:
Open up a command prompt and type "ipconfig /all" post the results for your Local Area Connection here.

Should be something similar to:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 00-1F-D0-DA-9B-4F
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.0.0.113(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, January 19, 2012 6:53:00 AM
Lease Expires . . . . . . . . . . : Friday, March 01, 2148 11:40:59 PM
Default Gateway . . . . . . . . . : 10.0.0.1
DHCP Server . . . . . . . . . . . : 10.0.0.1



Here you go:


Windows IP Configuration

Host Name . . . . . . . . . . . . : NadimKuttab-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 50-E5-49-38-E8-50
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::3ce9:D 269:D 9e4:97c2%15(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{D1B998B0-CC82-4B57-BE0C-9EFA849AD06F}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter 6TO4 Adapter:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Score
0
January 24, 2012 8:40:18 PM

tomatthe said:
From looking at it, seems like ipv4 may be disabled.

Try using these to verify it's enabled.

http://windows.microsoft.com/en-US/windows7/Change-TCP-...



Followed the steps, followed netsh interface ipv4 install in command prompt. Restarted. No difference.

Do i need to assign a certain IP address manually for my IPv4 IP?? Its been automatic all this time, but as far as i can remember its meant to be....

Any more ideas?

Im getting desperate! I need this computer online asap!
Score
0
January 24, 2012 9:16:31 PM

No, assuming your router is setup as a dhcp server which it almost certainly is you don't need to setup a static ip. Does this line show up at all with ipconfig after making sure ipv4 was installed.

IPv4 Address. . . . . . . . . . . : 10.0.0.113(Preferred) ?

It should at least have an auto assigned 169.*.*.* ip. You may want to try uninstalling your nic and reinstalling.
Score
0
January 24, 2012 9:53:02 PM

tomatthe said:
No, assuming your router is setup as a dhcp server which it almost certainly is you don't need to setup a static ip. Does this line show up at all with ipconfig after making sure ipv4 was installed.

IPv4 Address. . . . . . . . . . . : 10.0.0.113(Preferred) ?

It should at least have an auto assigned 169.*.*.* ip. You may want to try uninstalling your nic and reinstalling.



I get this,

Autoconfiguration IPv4. . . . . : 169.254.151.194 (Preffered)

Also, what do you mean by re installing my nic? (If thats the driver, i've done that allready)

thx
Score
0
January 24, 2012 10:07:34 PM

Yeah I just meant uninstalling it from device manager and reinstalling it. It does seem like there is something screwy with the drivers since it didn't have ipv4 installed. You might want to try finding a newer driver for it, and installing that.
Score
0
January 24, 2012 10:26:56 PM

I have a disk with the driver on it, i've reinstalled it several times, to no avail. My driver is a: "Realtek PCIe Family Controller". I cant seem to find what model it is, any clue on that?
Score
0
January 24, 2012 10:43:27 PM

***Update

I just re installed the latest driver for my Ethernet Controller, still have the same problem.

If it is of any help, the connection type is "public", and the network is an "Unidentified network".

****Update!

I've given the computer in for Repairs, I spent another 4 hours trying to solve the problem. I've done everything short of formatting the entire computer and reinstalling everything.

But Thanks again for all your help! Much appreciated! :) 
Score
0
January 25, 2012 2:22:37 PM

Would be nice to know what ends up being the issue, please repost once it's fixed if you can.
Score
0
January 25, 2012 11:50:11 PM

tomatthe said:
Would be nice to know what ends up being the issue, please repost once it's fixed if you can.



Will do
Score
0
January 27, 2012 1:11:39 AM

Hi, i'd read the whole thread, and i find that this is quite a tricky case. Since you've reinstalled the NIC for your desktop, im sure the settings will be back to default, but im suggesting if you check out the properties of your Local area connection, it wouldn't hurt.

Make sure your IPv4 is checked as well, and configure your IPv4 to obtain address automatically. Do not adjust the speed of the network card as it doesnt do much. Let it go as default.

Go to internet explorer and go to the the tools tab, and internet option > connections tab > LAN settings, and let it go as automatically detect settings and do not key in proxy if you've done so earlier on.

Im quite interested in the outcome too. Do update the post so the people out here can learn something new =D
Score
0
January 30, 2012 3:30:43 PM

jesperloh said:
Hi, i'd read the whole thread, and i find that this is quite a tricky case. Since you've reinstalled the NIC for your desktop, im sure the settings will be back to default, but im suggesting if you check out the properties of your Local area connection, it wouldn't hurt.

Make sure your IPv4 is checked as well, and configure your IPv4 to obtain address automatically. Do not adjust the speed of the network card as it doesnt do much. Let it go as default.

Go to internet explorer and go to the the tools tab, and internet option > connections tab > LAN settings, and let it go as automatically detect settings and do not key in proxy if you've done so earlier on.

Im quite interested in the outcome too. Do update the post so the people out here can learn something new =D




Alright, an update on everything.

After giving it in for repairs, and the people over in tech support calling me to say that my computer is fine, I got it back and saw that the problem was still there. No internet. So I formatted the whole dam thing, reinstalled everything. Still no internet. Then I called my internet provider, they told me everything was ok with the line, but maybe my computer was blocked for whatever reason. After getting in touch with my school, they said they would have any possible blocked computers on my connection unblocked by tomorrow. I will post a reply tomorrow when I see if this worked or not! :) 
Score
0
January 30, 2012 10:37:32 PM

Wow.. hardcore.. you've gone down to the extreme for internet connection. Respect. Anyhow, im really curious about the out *wait for it......" come. =)
Score
0
February 10, 2012 1:24:20 PM

Alright, an update. My internet is now working fine again, it seems that for whatever reason my internet provider blocked my computer from the internet. They dont know why it was blocked, and said it was usually due to people connecting their computers to several different connections, which is apparently not allowed. As i didn't do that, I have no idea why i was blocked. They guy I talked to said it must have been a mistake. Anyway, all is solved. Took several weeks, but its done! :)  Thanks for the help guys!
Score
0
February 12, 2012 10:23:33 PM

Haha! Glad that you had your connection back! But i somehow sense that your ISP guy is smoking you with some excuses either with the mistakes they made, or they didnt know what's going on exactly.
Score
0
!