Sign in with
Sign up | Sign in
Your question

Black Ops 2 Question

Last response: in Graphics & Displays
Share
December 22, 2012 2:26:19 AM

Hey everyone, I recently purchased a GTX 660Ti Superclocked (Factory overclocked) for myself. It's amazing; I can play GTA IV, BF3, and Borderlands all on maxed out settings. Yet, when it comes to Black Ops 2, I lag. I already turned DoF down to low, and originally I had all other settings on high. Now they're on medium, and it's still lagging. The frames are dropping randomly, it's not steady lag. I tried capping my frames at 60, 120, and no cap at all. Can anyone tell me why this is happening?

More about : black ops question

a b U Graphics card
December 22, 2012 4:12:44 AM

That is supposed to be a game problem.
Reinstall it or install new patches
December 28, 2012 1:52:52 AM

Sumukh_Bhagat said:
That is supposed to be a game problem.
Reinstall it or install new patches

Nope, it isn't. All 660 Ti owners I've spoken to have a similar problem. I have the latest drivers and patches for the game.
Related resources
a b U Graphics card
December 28, 2012 2:26:02 AM

You have 310.70 version of Nvidia Drivers.
That driver is supposed to be Optimized for the game. :ouch: 
Never heard any other 660 Ti owner saying that.

Then maybe the game isn't optimized for GTX 660 Ti. :lol: 


December 28, 2012 2:38:05 AM

Sumukh_Bhagat said:
You have 310.70 version of Nvidia Drivers.
That driver is supposed to be Optimized for the game. :ouch: 
Never heard any other 660 Ti owner saying that.

Then maybe the game isn't optimized for GTX 660 Ti. :lol: 

Hmmm maybe not, and I saw that when I downloaded the driver and was happy haha. Is it maybe a problem with my Nvidia CP settings?
a b U Graphics card
December 28, 2012 2:41:16 AM

Your settings should be set on "Let the 3D Application Decide."

Or check and Optimize it on your Own.
December 28, 2012 2:49:02 AM

Sumukh_Bhagat said:
Your settings should be set on "Let the 3D Application Decide."

Or check and Optimize it on your Own.

Oh, I also have dual monitors. Should I set the "Multi-display/mixed-GPU acceleration" to Multiple or single display performance mode?
a b U Graphics card
December 28, 2012 9:12:29 AM

As I don't have a dual Monitor setup, I'm clueless.
So check out by Changing the settings and see which suits it better.
!