Sign in with
Sign up | Sign in
Your question

Unusal GPU useage on Arma 2 Only

Last response: in Graphics & Displays
Share
December 22, 2012 3:02:37 PM

Over the last few weeks, and probably months, i have wondering why my FPS in Arma:2 has been so low, at around 18FPS-30 in and around cities. This FPS for some people might be kind of good, but for me GTX 570, i believe not. After doing overclocking to my CPU which is a i7 3.4GHz to a 3.8GHz and a little GPU overclocking i saw still noo increase in performance.
As to overclock me GPU i installed a program named "MSI Afterburner", when playing the game i noticed something REALLY strange. In Arma:2 my GPU usage was only staying at around 15-20% 0_0.

Anyone know the problem?

More about : unusal gpu useage arma

a b Î Nvidia
a b K Overclocking
December 22, 2012 3:06:22 PM

And what CPU usage are you getting? Is something running in the background that shouldn't be?
December 22, 2012 3:23:58 PM

Sunius said:
And what CPU usage are you getting? Is something running in the background that shouldn't be?

After doing a bit of play, its AVGs at around 40-60 CPU USAGE
Related resources
a b Î Nvidia
a b K Overclocking
December 22, 2012 3:28:45 PM

Disable it while gaming. It should solve your performance issues.
December 22, 2012 3:38:24 PM

Sunius said:
Disable it while gaming. It should solve your performance issues.

How would i go about doing this?
- Sam
a b Î Nvidia
a b K Overclocking
December 22, 2012 3:45:17 PM

I have actually no idea - I have never used AVG. Isn't there an option to exit the program?
December 22, 2012 3:46:51 PM

Sunius said:
I have actually no idea - I have never used AVG. Isn't there an option to exit the program?

Oh, sorry, when i said AVG i was using it as a shorter version of the word average sorry xD
a b Î Nvidia
a b K Overclocking
December 22, 2012 4:16:39 PM

Oh :D . Could you check what's actually using up the CPU?
December 22, 2012 4:43:11 PM

Sunius said:
Oh :D . Could you check what's actually using up the CPU?

Mainly the game.
a b Î Nvidia
a b K Overclocking
December 22, 2012 4:48:44 PM

Could you try going into BIOS and disabling hyperthreading? Report the results: whether the lag is still present, and the CPU usage.
December 22, 2012 5:23:19 PM

Sunius said:
Could you try going into BIOS and disabling hyperthreading? Report the results: whether the lag is still present, and the CPU usage.

Ok, i will try it now. Expect results in 20mins.
a b Î Nvidia
a b K Overclocking
December 22, 2012 5:28:23 PM

Okay, will be waiting :) .
December 22, 2012 5:59:53 PM

Now getting around 28-44 FPS
CPU is still at around 40-60%
When i TAB out of game it goes back down to around 5-20% CPU.

December 22, 2012 6:01:19 PM

Sunius said:
Okay, will be waiting :) .

Forgot to add the message as a reply:
Now getting around 28-44 FPS
CPU is still at around 40-60%
When i TAB out of game it goes back down to around 5-20% CPU.

EDIT: GPU load is around 30-40% now. Progress is in site.... xD
a b Î Nvidia
a b K Overclocking
December 22, 2012 6:24:10 PM

Ok good. Could you open Resource Monitor (windows 7 program), CPU tab, sort the processes by average CPU and play the game for ~20 mins? Then, could you minimize the game and capture a screenshot of the Resource Monitor and upload it to www.imageshack.us (don't forget to select "Do not resize" option!)?
December 22, 2012 6:29:07 PM

Will do
a b Î Nvidia
a b K Overclocking
December 22, 2012 8:07:59 PM

Yea sure it's fine. Just listed one website so you don't reply "I don't know how to post pictures" :) .

The screenshot is with hyperthreading disabled, yes?
December 22, 2012 8:33:29 PM

Sunius said:
Yea sure it's fine. Just listed one website so you don't reply "I don't know how to post pictures" :) .

The screenshot is with hyperthreading disabled, yes?

Yes, it is
a b Î Nvidia
a b K Overclocking
December 23, 2012 9:24:12 AM

OK I'm stumped. Neither CPU or GPU is maxing out.

At this point I'd suggest reinstalling both the game and Nvidia drivers.
December 23, 2012 1:45:20 PM

Sunius said:
OK I'm stumped. Neither CPU or GPU is maxing out.

At this point I'd suggest reinstalling both the game and Nvidia drivers.

I have already reinstalled game, but quick question... is there a way i can temporally disable HyperThreading while playing games?, because in most games it gives me like a 30-40% increase in FPS :D 
December 23, 2012 1:48:26 PM

I had ARMA do that to me once. When I had certain settings enabled (Cant remember what, sorry) the GPU wouldnt be fully used, like about 50-60%

Wasnt any kind of bottleneck issue with me either.
I7-2600 Quad 3.4Ghz and A GTX 660
a b Î Nvidia
a b K Overclocking
December 23, 2012 1:57:48 PM

AuXDubz said:
I have already reinstalled game, but quick question... is there a way i can temporally disable HyperThreading while playing games?, because in most games it gives me like a 30-40% increase in FPS :D 


I don't think so. Which games does it give performance increase?
December 23, 2012 2:04:42 PM

Far Cry 3, and Arma...
There must be some patch
a b Î Nvidia
a b K Overclocking
December 23, 2012 2:36:48 PM

Well, you can just stay with it disabled, can't you?
December 23, 2012 3:14:37 PM

Sunius said:
Well, you can just stay with it disabled, can't you?

I also am a video content producer so hyperthreading for rendering videos and using photoshop is key.
a b Î Nvidia
a b K Overclocking
December 23, 2012 3:28:15 PM

I see.
!