HD 7970 Red screen crash and reboot in games

Hey I was wondering if anyone could help me. I only got this new sapphire HD 7970, vapor-x ghz edition yesterday and tried to install it today, I haven't overclocked it at all. I updated it with the latest drivers and initially I was wowed by its performance in Crysis 2, max settings and great fps. However, after 4 or 5 minutes the screen went red and there was a stuttering sound then the system rebooted. I tried it with deus ex HR and that did the same. Planetside 2 ran at an average of 59 fps but after 10 minutes dropped right down to 10fps or lower after an initial stutter. I can't find a fix anywhere, it seems a lot of these red screens are happening with Nvidea crads but not so much AMD.

Another thing I noticed was that occasionally small white lines would flicker across the screen when idle at the desktop. I initially thought it was the hdmi cable being loose but I'm not so sure.

I was running the same system with a 6870 before and it was all smooth, no problems. So I'm wondering what to do, I'm not sure how amazon handle GPU returns and have heard sapphire have terrible RMA times in the UK, up to 30 days so if I can I'd like to try to sort it out :(

Thanks.

Here's my system:
GPU: sapphire amd hd 7970 vapor-x ghz edition(stock)
CPU: I5 3570K at 3.4ghz(stock)
Ram: 8gb kingston hyper x 1866
HDD: 2x 1tb seagate 7200rpm
PSU: 650w Antec Truepower
Mobo: Msi z77a-g43
Case: Zalman z-11 plus
OS: Win8 pro 64bit
26 answers Last reply
More about 7970 screen crash reboot games
  1. 1.4 ghz? I am pretty sure thats a typo But if its not "And I know it is" then the CPU is definitely bottlenecking your GPU.
  2. Commandermadi said:
    1.4 ghz? I am pretty sure thats a typo But if its not "And I know it is" then the CPU is definitely bottlenecking your GPU.

    yup 3.4ghz, fail on my part.
  3. I guess your GPU might be overheating, do you have good cooling in that case?
  4. Doesn't seem to be, it sits at 33 idle, my cpu has a i30 arctic freezer HS on it sitting it at around 37. GPU seems to get up to 59/60C so doesn't seem bad.

    I was able to run the uniengine benchmarks fine with 40 fps with everything including tesselation and it didn't crash. That at its most heavy was pushing the gpu to 60C but still.
  5. Try to roll back to the previous stable drivers and see if that problem goes away.
  6. Any advice on the best way to do that? Finding the old drivers and unistalling the current ones that is.
  7. I am not pretty sure how AMD work but the latest drivers I heard off are the 12.11. right?
  8. I think the beta is 12.11, I'm running 12.10. Reckon giving the beta drivers a go will be worth a shot?
  9. Yes, definitely go with the beta drivers and see if that problem disappear and let me know.
  10. Should I just install it over these drivers or should I uninstall these first?
  11. Uninstall 12.10 first then freshly install the beta ones.
  12. Commandermadi said:
    Uninstall 12.10 first then freshly install the beta ones.

    Thanks I'll get to it :)
  13. You are most welcome. Do it and inform me :)
  14. I tried the beta drivers with crysis 2 but it still crashed after about 5 minutes, although this time it only ctd'd not red screen and reboot.

    I have noticed that there were 2 8pin-double 4pin molex connectors for the power but I hadn't plugged both molex for each 8 pin connector. Wondered if I was doing something wrong here? (connected both now).

    Here are some pics: http://i.imgur.com/L5wmp.jpg
    http://i.imgur.com/74jXc.jpg
    http://i.imgur.com/vCfEt.jpg
  15. I guess that is the problem. Tried after plugging both?
  16. Still crashes but not with reboot so far, notice the card makes a high pitch whiny noise whilst playing games (not loud though). Reckon the plugs are configured correctly, both molex pins are attached to a branch of connectors that go to a 6pin-psu.
  17. Hmmm, that is pretty strange. Is the card stably fixed? Or does it move little forward and backward when you move it by your hand?
  18. I moved it slightly over to the side as it could have been off a little being straight and made sure it had actually gone into the PCI slot with a little force but should be in.

    The front protion doesn't move but the back isn't supported and has a tiny wiggle. The power cables above it aren't flexible at all and slightly touch my side panel I think although I can't tell.

    My psu is modular and one of the extenders is plugged in like this: http://i.imgur.com/24dt1.jpg
    I assume that's ok?
  19. Like what? I guess you missed posting something here.
  20. Yeh was just edditing it in : http://i.imgur.com/24dt1.jpg
  21. That looks fine. May be restart the game and try now?
  22. Still CTD after a little while of play, didn't restart though. Hm.
  23. Ok after all this fretting, I realised that I had left a residual clock on my cpu to 4ghz but didn't think it had set, so it seemed to have caused all this. Reset it to stock and have been playing games for the past couple of hours without crashing.
  24. So, problem solved now?
  25. Hopefully, thanks for the help and sorry for going in circles.
  26. Nevermind, I was glad to help. To mark this topic as solved, please choose a best answer :) Thanks.
Ask a new question

Read More

Graphics Cards HD Graphics