Sign in with
Sign up | Sign in
Your question

Home Network Advice

Last response: in Networking
Share
January 26, 2012 8:16:14 PM

Hi guys

So I've got a home windows network, 2008 R2 server as DC, DHCP and DNS. Internet comes in from Virgin with a 86.x.x.x IP - all is good.

What I want to do though is virgin hit my linksys router with an IP of 192.168.0.99 and this share the connection on my domain. So topology would be ...

VM > Router > Server 2008 adapter 1

Server 2008 adapter 2 > Switch > Network clients

I've tried ICS but just can't get it working with the router in the equation. I'd want the router to handle wireless still but not DHCP so giving statics to wireless devices is fine I just want them to communicate with devices on my network, wired or wireless.

2008 server runs...
DC - 192.168.0.2 (adapter 2)
DHCP - 192.168.0.2 (adapter 2) range 192.168.0.10 to 192.168.0.90
Default gateway - 192.168.0.1
DNS - 192.168.0.2 (adapter 2)

Not sure what to set adapter 1 to?? This connects straight to the router but routers DHCP is off. Adapter 2 into my switch.

Any advice will be really appreciated, I've tried loads now to no avail so I've resorted to getting help :) 

Thanks
P7

More about : home network advice

January 27, 2012 5:22:57 AM

why are you trying to use two NICs on the server?

why does the Linksys have IP 192.168.0.99?

which device has IP 192.168.0.1?

the way you set it up the wireless and devices wired to the switch will never be able to see each other.

try this:

router IP 198.168.0.1

VM > Router> Switch > Network clients + Server 2008 adapter 2

all network clients wired and wireless will receive IP from server and will be able to see each other.

you could assign IP 192.168.0.3 to Server 2008 adapter 1 and use it for the DNS and enable load balancing
January 28, 2012 1:11:12 PM

Emerald said:
why are you trying to use two NICs on the server?

why does the Linksys have IP 192.168.0.99?

which device has IP 192.168.0.1?

the way you set it up the wireless and devices wired to the switch will never be able to see each other.

try this:

router IP 198.168.0.1

VM > Router> Switch > Network clients + Server 2008 adapter 2

all network clients wired and wireless will receive IP from server and will be able to see each other.

you could assign IP 192.168.0.3 to Server 2008 adapter 1 and use it for the DNS and enable load balancing


Hi Emereld

Thanks for your reply, appreciate the help.

So it did make me wonder why all along I was attempting to feed internet through an adapter on the server to share to it's other adapter which was on the network - I was going round the houses!!

So now this is how it looks...

Virgin > Router (192.168.0.99) > Switch layer 2 (upstairs) > Switch layer 3 (downstairs) > Server 2008 adapter (192.168.0.1 - DNS+DHCP)

The servers default gateway is set as the routers 192.168.0.99 IP - is this correct?

I've also got the router listed as this IP as well under server options for DHCP - again, am I doing this right?

I'm having some really slow speeds between all network clients and slow internet speeds except on the server. I really can't fathom why, my layer 3 switch is collecting an IP from the DHCP scope so it's on the same network. No loopbacks either.

On one of my network clients, when I did an ipconfig I was getting a default gateway of 0.0.0.0 along with 192.168.0.99. I had to use netsh to get rid of this and it hasn't returned.

Also, would I gain much benefits from load balancing DNS?

Any further advice/help is really appreciated.

Thanks
P7
!